cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.Pietschmann" <j3322...@yahoo.de>
Subject Re: FOP problems with 2.1m2
Date Mon, 09 Jun 2003 14:35:17 GMT
Spectron International, Inc. wrote:
> I'm having some problems with FOP in Cocoon 2.1m2. I have a pipeline that
> creates the xsl-fo document and then I convert it to PDF. If I save the
> xsl-fo and run it directly through FOP it works ok. When run from Cocoon it
> gives me the following exception:
> 
> 15:29:10.698 WARN!! Error for
> /msim/pdf/DiscrepancyAnalysis?batDate=2003-06-05&endDate=2003-01-05
> java.lang.NoSuchMethodError:
> org.apache.batik.bridge.UnitProcessor.createContext(Lorg/apache/batik/bridge
> /BridgeContext;Lorg/w3c/dom/Element;)Lorg/apache/batik/util/UnitProcessor$Co


This typically happens if there is a mismatched version of Batik
in the classpath. Unfortunately, some Cocoon distributions are
distributed with a Batik jar which does not match the interfaces
the FOP jar from the same distribution uses. You can fix this by
grabbing a recfent FOP distribution and replace the fop and batik
jars in the Cocoon lib by the FOP and Batik jars from the FOP
distribution. This may have negative impacts on Cocoons SVG
serializer though, so you should not use a PDF generating pipeline
which uses embedded or referenced SVGs and a SVG generating
pipeline at the same time.

J.Pietschmann


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message