cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Problems with umlaut in cocoon2.04
Date Tue, 03 Jun 2003 19:15:04 GMT
Hello Frank,

are you generating the XML declaration (<?xml version="1.0" 
encoding="ISO-8859-1"?>) by hand (so as string) or via some XML methods 
or tags?

Joerg

Przybilla, Frank wrote:
> Hello Cocoon community,
> 
> I hope there is somebody out there who can explain me the following:
> 
> I'm using cocoon 2.0.4 together with tomcat.1.4.24 and jdk1.41 and I have
> the following szenario, which
> worked well with cocoon 2.01, tomcat4.0 and jdk1.3.x. 
> 
> In this szenario I have a jsp which generates an xml document which includes
> characters like ä,Ä,ö,Ö etc. 
> Therfore I specify <?xml version="1.0" encoding="ISO-8859-1"?>. Additionally
> I'm using the folowing pipline
> definition in the sitemap: 
> 
> <map:match pattern="JAVA.Login_Screen">
>     <map:generate type="jsp"
> src="/maxess/Xplorer/jsp/Screens/Login_Screen_JAVA.jsp"/>
>     <map:serialize type="xml"/>
>    </map:match>
> 
> So I'm using a jsp generator which dynamically generates the xml. I also set
> the correct ecoding for the xml serializier component (ISO-8859-1).
> But with cocoon 2.04 the output is not correct, because the umlaut is not
> correctly encoded and presented . As I mentioned before, everything
> works fine with cocoon2.01. What must be changed so that the encoding is
> correct?
> 
> 
> With best regards
> 
> Frank


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message