cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stavros Kounis <gou...@osmosis.gr>
Subject [solution] Re: Error setting up cocoon
Date Tue, 27 May 2003 21:49:31 GMT
yes that's it geoff


i had the same problem

after cocoon build
i have just copy all cocoon-2.1/lib/endorsed/  jars into tomcat/common/endorsed
but cocoon use to give me blank pages

after your post i check the content of common\endorsed and WEB-INF\lib
and left in common\endorsed only the same jars version that are in
WEB-INF\lib too, deleting all other stuff.

i have left untouched jars that are in common\endorsed and not in
WEB-INF\lib\endorsed

no i have cocoon up and run.

content of my tomcat\common\endorsed:
xalan-20030506.jar
xercesImpl-2.4.4.jar
xml-apis.jar
xmlParserAPIs.jar

hope that this will help all other people with this problem


--stavros
On Tue, 27 May 2003, Geoff Howard wrote:

> That root cause:
> java.lang.IllegalAccessError: class
> org.apache.xml.dtm.ref.sax2dtm.SAX2DTM2$AncestorIterator cannot access
> its superclass
>
> is 99.9% sure to be the endorsed dir issue that you think you've fixed.
> I'm pretty sure this is what happens when two different versions of
> the jars are in common\endorsed and WEB-INF\lib.  Make sure they are
> the same, and for that matter, the ones in your jdk's lib\endorsed.
> Old versions hanging around must be deleted.
>
> HTH,
> Geoff
>
> At 02:41 PM 5/27/2003, you wrote:
> >Hi,
> >
> >I'm trying to install cocoon 2.1M2 under Tomcat "Apache
> >Tomcat/4.1.24-LE-jdk14" running with j2sdk1.4.1_02. I have xml-apis.jar
> >and xercesImpl-2.4.0.jar in the common\endorsed directory under Tomcat,
> >and I tried to put both xalan-2.5.0.jar and xalan-20030506.jar there
> >too, but I keep running into the same problem: the page
> >http://localhost:8080/cocoon/ comes back blank, and there is an error in
> >tomcat's localhost_log (see stack trace below).
> >
> >I tried building cocoon from sources using both 'build clean war' and
> >'build -Dinclude.webapp.libs=true clean war' (I don't know what that
> >flag does, I think I saw the instruction on the xmlform howto). There
> >was some 'installwar' target mentioned somewhere, but it doesn't appear
> >to work or exist :)
> >
> >I tried cocoon 2.0 for jdk1.4 before, and it deployed fine, but I wasn't
> >able to get xmlform working with it, which is the primary reason I want
> >to set it up in the first place. Is the xmlform module supposed to work
> >with cocoon 2.0?
> >
> >Thanks,
> >
> >- Eugene Kaganovich
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message