cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Li Wang <Li.W...@first-franklin.com>
Subject Help please: CastorTransformer in Cocoon 2.0.4
Date Fri, 16 May 2003 17:55:44 GMT
I need to use CastorTansformer in my project, but I couldn't get the
CastorTransformer sample shipped with Cocoon 2.0.4 binary distribution to
work. I am not sure if it's because the sample has problem or I did
something wrong. I'm running Cocoon 2.04 with Tomcat 4.1.24. Can anyone
please enlighten me if I am missing anything here.

The following is what I've done and the result I got.

Steps:

1) fix test.xml, as there is an error in the namespace.
   old: <zoo xmlns:castor="http://castor.exolab.org/cocoontransfomer">
   new: <zoo xmlns:castor="http://castor.exolab.org/cocoontransformer">

2) issue URL request: http://localhost/cocoon/mount/castor/index.html

Result: 

<?xml version="1.0" encoding="UTF-8" ?> 
- <zoo xmlns:castor="http://castor.exolab.org/cocoontransformer">
  <castor:InsertBean name="Mouse" /> 
  <castor:InsertBean name="Lion" /> 
  <castor:InsertBean name="Hamster"
mapping="castor-mappings/test-mapping_de.xml" /> 
  <castor:InsertBean name="Wale" /> 
  <castor:InsertBean name="Elefant" scope="session" /> 
  <castor:InsertBean name="Elefant" scope="request" /> 
  </zoo>

I really don't know why the value objects were not marshaled and inserted
into the XML document.

Thanks,

Li







 

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message