cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Apperant <xsl:include/> Failure
Date Wed, 28 May 2003 08:11:00 GMT
Dave Allen Barker Jr wrote:
 > Stylesheets that use <xsl:inclue/> generate a "Unable to get transformer
 > handler" error.  Any help would be greatly appreciated!  I hope the
 > following information is insightful.

Hello Dave,

not so long ago there was a problem with path resolving in XSLTC. AFAIK 
it's fixed, I only don't know if it was before or after the 2.1M2 
release. Maybe Bruno can help here.

The problem was with the path resolving in XSLTC, you can switch to 
Xalan and it should work.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17825
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19324

Joerg

> My Process
> 
> 1.  Exploring the LinkRewriter Demos, I went to the "sitedemo".
> 
> 2.  org.apache.cocoon.ProcessingException: Failed to execute pipeline.: 
> org.apache.avalon.framework.CascadingRuntimeException: Error accessing 
> attribute '/site/index/@href' from input module 'linkmap'. Error using 
> source cocoon:/linkmap
> 
> 3.  So, I tried to bring up the "linkmap", and got:  
> org.apache.cocoon.ProcessingException: Unable to get transformer handler 
> for stylesheets/relativize-linkmap.xsl: 
> org.apache.excalibur.xml.xslt.XSLTProcessorException: Exception in 
> creating Transform Handler
> 
> 
> Things I've Tried
> 
> *  relativize-linkmap.xsl imports dotdots.xsl.  If I replace the 
> <xsl:include/> with the content of the dotdots.xsl stylesheet, the 
> problem dissapears.
> *  If I visit other samples that use <xsl:include/>, the problem follows.
> *  Trying Cocoon 2.1-M1, this problem does not exist.
> 
> 
> My Environment
> 
> Cocoon Version:  2.1m2
> Servlet Container:  Jetty (included with Cocoon)
> Java Version:  1.4.1_02
> OS:  Windows XP
> 
> 
> I didn't see anyone report the problem, and since it's so fundamental, I 
> figure it's me.  So, thank you in advance for any pointers you can give!


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message