cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sully <stinky...@yahoo.com>
Subject Errors cause blank document instead of error message
Date Thu, 20 Mar 2003 04:50:49 GMT
Hi,

I'm having some trouble with a subsitemap of mine...

if I access a pipeline which exists and there are no
errors anywhere in the execution of that pipeline then
it works perfectly.

however if there is an error anywhere in the execution of the pipeline 
then it returns an empty document (0 bytes).

I have an error handler in the pipeline as follows, however I have 
exactly the same output without it.

<map:handle-errors>
    <map:serialize type="xml"/>
</map:handle-errors>

If I access pipelines in my root (is that the proper term?) sitemap 
which have errors then they display the errors as per the default error 
stylesheet (ones without errors display fine).

the mounting pipeline in the root sitemap is:

<map:match pattern="preview/*/**">
     <map:mount uri-prefix="preview/{1}/" src="preview/{1}/sitemap.xmap"/>
</map:match>

(removing the sitemap.xmap from in there doesn't change anything)

I haven't been able to see anything in the logs (though that may well be 
because of my lack of knowledge about logging).

any help greatly appreciated.



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message