cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Riedel" <mee...@gmx.de>
Subject Re: Problems with Cocoon 2.1 dev (CVS)
Date Sun, 23 Mar 2003 22:56:07 GMT
> today i wanted to build and install the newest
> Cocoon 2.1 dev from CVS. I did it like always (build war),
> but this time the compiled Cocoon didn't work.

I had the same problem, even though a few days already passed. The
Cocoon-Servlet works, but only deliveres the error-message you mentioned:

>  Request Processing Failed
>
> Message: Cocoon engine failed in process the request
>
> Description: The processing engine failed to process
> the request. This could be due to lack of matching or
> bugs in the pipeline engine.
>
> Sender: org.apache.cocoon.servlet.CocoonServlet
>
> Source: Cocoon Servlet
>
> Request URI
> request-uri
> /cocoon/
>
> Apache Cocoon 2.1-dev

It is displayed, whenever you request the welcome-page, or any other page
which should normally apear. If a resource which is not specified in the
sitemap is requested, another error-message apears. But since it states

Also when I build I get the following error at the end:

  validate-xdocs:
  Conducting validation of core XML documentation.
  Validating all **/book.xml instances using RELAX NG ...
  Fatal error: exception "java.net.MalformedURLException" thrown: no
protocol: dtd/book-cocoon-v10.dtd

  BUILD FAILED

file:///G:/Dokumente%20und%20Einstellungen/Michael/Eigene%20Dateien/WebSites
/cocoon-2.1/build.xml:835: Validation failed, messages should have been
provided.

... but anything else seams to be built correctly. Also when I set
validate.xdocs=false in local.build.properties, the error does not occur,
and the build is successfull. So I don't think, the problem lies here.

However, I have no clue what could still be wrong. None of the hints from
the mail-list worked for me so far. And I've also tried several CVS updates
by now, so it's not a temporar problem.

-- Michael Riedel



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message