cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject RE: problems with images
Date Tue, 11 Mar 2003 14:18:37 GMT
You are not serving these images through cocoon with these urls.  Your main 
page is at (after breaking out of the frame) 
http://http.dyndns.org/cocoon/soundpool/soundpool.html, so your cocoon 
webapp is mounted at /cocoon - but you are referencing the images as 
/soundpool/images.  When I browse to 
http://http.dyndns.org/soundpool/images/background.gif I get an image, but 
http://http.dyndns.org/soundpool/images/musicnews.gif I get a 404 response 
from the webserver, not cocoon.  From this I deduce that your webserver 
(probably apache?) root is set to C:\tomcat\webapps\ ?  Which means that if 
you do a directory listing of c:\tomcat\webapps\soundpool\images\ I would 
bet there is no musicnews.gif in there.

So far, this is not a cocoon issue.

Secondly, browsing to /cocoon/soundpool/images/background.gif (and 
musicnews.gif) gives a cocoon resource not found, which implies that your 
sitemap is still not configured correctly.

Check:
- Is the resource reader configured in map:readers?
- Is your map:match in a pipeline?
- Exactly what matches you should be using depends on how you have your 
sitemaps set up.  If this is from a root sitemap, it should match 
pattern="/soundpool/images/*.gif" and map:read src="{1}.gif" and vice versa 
for *.jpg
NOTE: because you have this webapp in /cocoon mount, these matches will 
need to be referenced as /cocoon/soundpool/images/... from the outside, 
including your src attributes.
- make absolutely sure the images are in the directory you think they are

Geoff

At 08:46 AM 3/11/2003, you wrote:
>Geoff,
>
>All the different versions of how I have tried to link the image are
>different methods I tried and not been successful with.
>
>To summarise what I have done:
>
>1. I have added the readers into my pipelines in my sitemap
>2. I have tried the following ways to link the images:
>
>
>background="/soundpool/images/background.gif" (works)?
>
>src="/soundpool/images/background.gif" (doesn't work)
>
>src="/soundpool/images/musicnews.gif" (doesn't work)
>
>src="C:/tomcat/webapps/soundpool/images/background.gif" (doesn't work)
>
>file://C:\tomcat\webapps\cocoon\soundpool\images\databasequeries.gif
>(doesn't work)
>
>
>I believe the first one should work when I have the readers in my
>pipeline, but it only works on the backdrop?
>
>Could someone tell me all the code that they have written in all
>relevant files to make images display.
>
>
>Thanks,
>
>Richard.
>
>
>
>-----Original Message-----
>From: Geoff Howard [mailto:cocoon@leverageweb.com]
>Sent: 11 March 2003 13:28
>To: cocoon-users@xml.apache.org
>Subject: Re: problems with images
>
>To make matters worse - I found the following in the html:
><body
>background="C:\tomcat\webapps\cocoon\soundpool\images\backgroundpda.gif"
> >
>
>That would explain a lot...
>
>Geoff
>
>At 07:58 AM 3/11/2003, you wrote:
> >On 11.Mar.2003 -- 11:44 AM, Richard Cunliffe wrote:
> > > > From: Christian Haul [mailto:haul@dvs1.informatik.tu-darmstadt.de]
> > > > On 11.Mar.2003 -- 11:20 AM, Richard Cunliffe wrote:
> >
> > > > > Have tried changing the image to another, and it doesn't show
>anymore.
> > > > > When I revert it back to the backdrop image, it starts to work
> > > > again???
> > > >
> > > > Probably browser cache.
> > > >
> > > > I believe Charle's answer bears the key: The matches for your
>readers
> > > > are outside of a map:pipeline.
> > > >
> > > > I have put them within the pipeline now and still only the
>backdrop
> > > > works. I have also discovered if you change the image, then
>nothing
> > > > shows.
> >
> >This is from your sitemap.xmap:
> >
> >     <map:match pattern="**.gif">
> >         <map:read mime-type="image/gif" src="soundpool/images/*.gif"/>
> >     </map:match>
> >
> >     <map:match pattern="*.jpg">
> >        <map:read mime-type="image/jpg"
>src="soundpool/images/{1}.jpg"/>
> >     </map:match>
> >
> >The gif pipeline does not use {1} like the jpg one does -- this is a
> >problem. If you need to match arbitrarily deep paths, consider
> >switching to the regexp matcher.
> >
> >If it all doesn't help, look at the access.log and sitemap.log. Try to
> >reconstruct which matchers fire. It will sure provide some hints.
> >
> >         Chris.
> >--
> >C h r i s t i a n       H a u l
> >haul@informatik.tu-darmstadt.de
> >     fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> >For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
>For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
>For additional commands, e-mail: cocoon-users-help@xml.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message