cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chad Small <chad.sm...@definityhealth.com>
Subject The hsqldb cannot be used inside a WAR file ERROR
Date Wed, 19 Mar 2003 20:34:37 GMT
Hello,

I'm trying to install Cocoon 2.0.4 on Weblogic 5.1


Thanks to Uwe, and the archived message at the end of this message that 
I found to get me started.  But I'm now getting this error in 
my WEB-INF/logs/error.log file:

ERROR   (2003-03-19) 13:15.11:513   [core.manager] (Unknown-URI)
Unknown-thread/ExcaliburComponentManager: Caught an exception trying to
initialize the component handler.
org.apache.avalon.framework.context.ContextException: The hsqldb cannot be
used inside a WAR file.
	at
org.apache.cocoon.components.hsqldb.ServerImpl.contextualize(ServerImpl.java
:131)
	at
org.apache.avalon.excalibur.component.DefaultComponentFactory.newInstance(De
faultComponentFactory.java:229)
	at
org.apache.avalon.excalibur.component.ThreadSafeComponentHandler.initialize(
ThreadSafeComponentHandler.java:98)
	at
org.apache.avalon.excalibur.component.ExcaliburComponentManager.initialize(E
xcaliburComponentManager.java:513)
	at org.apache.cocoon.Cocoon.initialize(Cocoon.java:270)
	at
org.apache.cocoon.servlet.CocoonServlet.createCocoon(CocoonServlet.java:1276
)
	at
org.apache.cocoon.servlet.CocoonServlet.init(CocoonServlet.java:485)
	at
weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java
:495)
	at
weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.ja
va:453)
	at
weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.jav
a:442)
	at
weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.jav
a:361)
	at
weblogic.servlet.internal.ServletContextImpl.preloadServlet(ServletContextIm
pl.java:741)
	at
weblogic.servlet.internal.ServletContextImpl.preloadServlets(ServletContextI
mpl.java:715)
	at
weblogic.t3.srvr.HttpServer.initServletContexts(HttpServer.java:643)
	at weblogic.t3.srvr.HttpServer.start(HttpServer.java:442)
	at weblogic.t3.srvr.T3Srvr.start(T3Srvr.java:1320)
	at weblogic.t3.srvr.T3Srvr.main(T3Srvr.java:832)
	at java.lang.reflect.Method.invoke(Native Method)
	at weblogic.Server.startServerDynamically(Server.java:131)
	at weblogic.Server.main(Server.java:92)
	at weblogic.Server.main(Server.java:58)



Weblogic still starts up and this is what shows up when I 
hit http://localhost:7001/cocoon/ (don't think related to 
problem, but thought I would include it):


type fatal

message The system cannot find the file specified

description java.util.zip.ZipException: The system cannot find the file
specified

sender org.apache.cocoon.servlet.CocoonServlet

source Cocoon servlet

stack-trace

java.util.zip.ZipException: The system cannot find the file specified
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.(ZipFile.java:110)
	at java.util.zip.ZipFile.(ZipFile.java:125)
	at
weblogic.utils.zip.ZipURLConnection.getInputStream(Handler.java:40)
	at
org.apache.cocoon.components.source.URLSource.getInputStream(URLSource.java:
275)
	at
org.apache.cocoon.components.source.AbstractStreamSource.getInputSource(Abst
ractStreamSource.java:161)
	at
org.apache.cocoon.components.source.DelayedRefreshSourceWrapper.getInputSour
ce(DelayedRefreshSourceWrapper.java:144)
	at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.generat
eResource(ProgramGeneratorImpl.java:387)
	at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.createR
esource(ProgramGeneratorImpl.java:353)
	at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.load(Pr
ogramGeneratorImpl.java:312)
	at org.apache.cocoon.sitemap.Handler.run(Handler.java:267)
	at java.lang.Thread.run(Thread.java:484)


request-uri

/cocoon/

path-info



Here are the Cocoon jars I'm including in my classpath at this point:

set
C2_CLASSPATH=%C2%/xercesImpl-2.0.0.jar;%C2%/xalan-2.3.1.jar;%C2%/hsqldb-1.7.
1.jar;%C2%/cocoon-2.0.4.jar;%C2%/avalon-framework-20020627.jar;%C2%/logkit-2
0020529.jar;%C2%/excalibur-logger-20020820.jar;%C2%/excalibur-sourceresolve-
20020820.jar;%C2%/excalibur-pool-20020820.jar;%C2%/excalibur-component-20020
916.jar;%C2%/excalibur-instrument-20021108.jar;%C2%/xml-apis.jar;%C2%/excali
bur-collections-20020820.jar;%C2%/excalibur-xmlutil-20020820.jar;%C2%/servle
t_2_2.jar;%C2%/excalibur-monitor-20020820.jar;%C2%/cocoon-scratchpad.jar;%C2
%/resolver-20020130.jar;%C2%/commons-jxpath-1.0.jar;%C2%/excalibur-datasourc
e-vm12-20021121.jar

>From Uwe's message, it seems like this is possible (although Uwe was 
on V2.0.3 and I'm using V2.0.4).

Any help would be very appreciated.
thanks,
chad.


<<
*	From: Uwe Gerger 
*	Subject: Re: Please Help: Problems with Cocoon2 V2.03 with Bea
WebLogic5.1 
*	Date: Mon, 03 Mar 2003 06:36:01 -0800 

Hello to all interested people,
I could run Cocoon2.0.3 on Bea WebLogic5.1:
The following steps are necessary:
1) In your start-script of Bea-server add to the JAVA_CLASSPATH all the
libraries you found in your cocoon-distribution;
2) In the web.policy-file set in the last grant section add "permission
java.security.AllPermission;" for the first run
after you have cocoon running you can try to set the permissions you
need!


The same procedure I've done on SOLARIS with BeaWebLogic 5.1!

Good luck!
        Uwe
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message