cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Error running the cocoon war file on Tomcat 4.0.4
Date Sat, 01 Mar 2003 14:21:34 GMT
Hello Shainal,

 > Is it possible that Tomcat is using some other JDK version, or JVM ?

you or your admin should know, under which JDK your Tomcat is running. 
At least it seems to be an older one than the one used for the build 
process.

 > Please help if you know what the problem is.

Yes, it's the incompatibility between two JDK versions. Compiling with 
1.4 and running with 1.3 will cause such an error.

Joerg


shainal panther wrote:
> Hello All,
> 
> I downloaded the source code for cocoon version 2.0.4, and ran the 
> webapp task to create the war file. I then copied the war file into my 
> web app folder on Tomcat 4.0.4.
> 
> However upon stopping and restarting Tomcat several times, it was not 
> able to see the "cocoon" webapp. I then went through the Tomcat log 
> files and found the following message :
> 
> HostConfig[localhost] Error deploying web application directory cocoon
> 
> java.lang.UnsupportedClassVersionError: 
> org/apache/cocoon/servlet/CocoonServlet (Unsupported major.minor version 
> 48.0)
> 
> Now upon going through the user's mail archive, I stumbled across 
> someone who had a similar problem, except that he had the wrong version 
> of the JVM.
> 
> However, my JAVA_HOME environment variable points to E:\j2sdk1.4.1_01, 
> which is version 1.4 and greater. Is it possible that Tomcat is using 
> some other JDK version, or JVM ? Please help if you know what the 
> problem is.
> 
> Thanks in advance.
> 
> Shainal.


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message