cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cummings, Charles Steven (UMC-Student)" <ste...@mizzou.edu>
Subject [2.1-dev] Problem with use-request-parameters
Date Mon, 31 Mar 2003 17:21:08 GMT
Hello all,

I'm having issues sending email to cocoon-users from my main email (cummingscs@netscape.net)
that I use for it, so I'm going to temporarily send email from this one.

I've got a problem with my XSLT transforms in my sitemap running a checked-out and built version
of cocoon from within the last two days. I use the parameter "use-request-parameters" in most
all of my XSLT's to fill the global parameters in the XSL transforms. In my "toplevel" sitemap
matches that are not embedded in an action, this works and the parameters are filled with
request values. But further into my sitemap, in matches that are embedded in an action (incidentally
the "auth-protect" action), the request values that I've tested to make sure they're in the
request are simply not getting passed into the XSLT which specifies "use-request-parameters".
It seems very specifically that the problem is with getting the values into the XSLT. Additionally,
for that XSLT, I even tried passing the request parameters explicitely using specifically
named parameters and the request-param input module. The values would still not go in!

I couldn't find a bug in the database. Is there a known problem with 2.1-dev that might cause
this for nested sitemap directives? Thanks.

/S 


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message