cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Piroumian" <kpiroum...@apache.org>
Subject Re: Antwort: i18n more!!!!!!!!! :(
Date Thu, 23 Jan 2003 09:42:01 GMT
RE: Antwort: i18n more!!!!!!!!! :(Take a look at the i18n samples XSP page
(/samples/i18n/simple.xsp) source. There is a form field where you can enter
text in any (supported by Java/Xalan) encoding and then get it back on the
same page (see Hello Tomcat! message).

I've checked that for all the present in the sample locales, including
Chinese, Japanese and Armenian (which are quite good at finding out any
Unicode issues).

--
  Konstantin

----- Original Message -----
From: Hong Gia Dinh
To: cocoon-users@xml.apache.org
Sent: Thursday, January 23, 2003 07:18
Subject: RE: Antwort: i18n more!!!!!!!!! :(


Thanks a lot, i applied it with encoding=utf-8 but it just can display some
international character!!! some cant!!!!!!
so .. do you know why and how to fix it??
i changed the encoding to ISO-8859-1 but i can not display any thing!!! does
cocoon 2.0.4 not support for this encoding???
Thanks a lot for help!!
Gia Dinh


-----Original Message-----
From: manfred.weigel@rzb.at [mailto:manfred.weigel@rzb.at]
Sent: 22 January 2003 18:02
To: cocoon-users@xml.apache.org
Subject: Antwort: i18n more!!!!!!!!! :(




Hello!
Do you use this Action in your pipeline?
<map:action name="set-encoding" src
="org.apache.cocoon.acting.SetCharacterEncodingAction"/>
<map:act type="set-encoding">
      <map:parameter name="form-encoding" value="utf-8"/>
</map:act>
If not, try to insert it before(!!!) your matchers, where the requests come
in. (inside the pipeline!!!)
cheers
manfred




hgdinh@sdcgrp.com am 22.01.2003 11:59:04
Bitte antworten an cocoon-users@xml.apache.org@inet
An:      cocoon-users@xml.apache.org
Kopie:
Thema:   i18n more!!!!!!!!! :(




Hi all
I am deploying my application on JBoss 3.0.4 and jdk 1.4 and cocoon 2.0.4
i can set and change language with static values OK but....!!!!!
when my request sent with unicode value and CR values in the text , the
ressponse always displays error characters and all CR are deleted!!!!!! ???
i dont know how to fix it???? as wella s sometimes it keeps  on confuses
between {../../locale} and {../../../locale}when upgrading cocoon
version??? why????? i am nearly dont know how and why those bug, althpough
i read all cocoon examples carefully??
cant you all tell me how to fix those bugs???
All your information are very appreciated!!
thanks a lot much!
GD









---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message