cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eduardo Zurita" <g000...@correo.cajacanarias.es>
Subject Cocoon, J2SDK 1.4.1_01 and Tomcat
Date Fri, 17 Jan 2003 12:05:23 GMT
Hello again,

    I have installed Tomcat 4.1.17 LE, my J2SDK is 1.4.1_01 and my Cocoon version is 2.04
targetted for JDK 1.4.
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Note:Cocoon includes all the packages required to run out of the box (included Xerces, Xalan
and FOP) so you don't need to download anything else to start.

Note:Due to the incompatibilities between JDK 1.3 and JDK 1.4, you have to choose between
a binary version targetted for JDK 1.2/1.3 and a version specially targetted for JDK 1.4.
Using a build targetted for one JVM on a different JVM may result in runtime errors.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    When I have downloaded Tomcat, I have chosen the "LE" version because in the Jakarta site
I can read:

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
JDK 1.4 LE: This is a lightweight binary distribution of Tomcat 4, designed to be run on JDK
1.4. It does not include any of the optional binaries or the necessary XML parser (which is
included in JDK 1.4). This build can be run on JDK 1.2+ by adding an XML parser. All the components
of this distribution are open source software. This package does not contain JavaMail, Java
Activation Framework, Xerces, JNDI or the JDBC Standard Extension
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Well, then I have installed Cocoon 2.04

Have I done the correct installation (versions point of view)?

What is the recommended versions (most stable) and reliable?

Have I to deactivate Xerces in JDK1.4 or in Cocoon? Have I two Xerces?

A little help would be appreciated.

Thanks,

Eduardo.
Mime
View raw message