cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hans Thomas Nordeck" <h.nord...@juwimm.com>
Subject can't get browser selector working
Date Tue, 21 Jan 2003 15:24:24 GMT
I want to use the browser selector in a mounted sitemap. The selector is
well defined in the components part of the sitemap.
The Parameter "viewType" never gets a value.
I can't get it working.  Does anybody has an idea what the problem is?
(I'm working with cocoon 2.1 dev, do you think that could be the problem?
cause for me everything looks right)

Thanks a lot for help!


<map:match pattern="*/**/content.html">
 <map:act type="cms.actions.template">
  <map:parameter name="parameters" value="true"/>
  <map:parameter name="language" value="{1}"/>
  <map:parameter name="path" value="{2}"/>
 <map:select type="browser">
         <map:when test="pocketexplorer">
          <map:parameter name="viewType" value="browser"/>
         </map:when>
         <map:otherwise>
          <map:parameter name="viewType" value="browser"/>
         </map:otherwise>
    </map:select>
  <map:generate type="CmsContent">
   <map:parameter name="parameters" value="true"/>
   <map:parameter name="viewComponentId" value="{viewComponentId}"/>
  </map:generate>

  <map:transform src="templates/{template}.xsl"/>

  <map:serialize type="html"/>
 </map:act>
</map:match>


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message