cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niket Anand" <niketan...@networkprograms.com>
Subject Cocoon-2.0 with JDK1.4
Date Sat, 14 Dec 2002 06:57:49 GMT
Hello,
I have using Cocoon-2.0 with JDK1.3.1 and it is working fine.
I am trying to run Cocoon-2.0 with JDK1.4 but it is giving Language
Exception error as

Cocoon 2 - Internal server error

----------------------------------------------------------------------------
----

type internal-server-error

message Language Exception

description org.apache.cocoon.ProcessingException: Language Exception:
org.apache.cocoon.components.language.LanguageException: Error compiling
sitemap_xmap: Line 0, column 0: could not parse error message: error:
Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/io/OutputStream.class). The major.minor
version '48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:12: Class java.io.OutputStream not found in
import. import java.io.OutputStream; ^ Line 0, column 0: could not parse
error message: error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/io/IOException.class). The major.minor
version '48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:13: Class java.io.IOException not found in
import. import java.io.IOException; ^ Line 0, column 0: could not parse
error message: error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/util/List.class). The major.minor version
'48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:15: Class java.util.List not found in import.
import java.util.List; ^ Line 0, column 0: could not parse error message:
error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/util/ArrayList.class). The major.minor
version '48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:16: Class java.util.ArrayList not found in
import. import java.util.ArrayList; ^ Line 0, column 0: could not parse
error message: error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/util/Map.class). The major.minor version
'48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:17: Class java.util.Map not found in import.
import java.util.Map; ^ Line 0, column 0: could not parse error message:
error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/util/HashMap.class). The major.minor version
'48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:18: Class java.util.HashMap not found in
import. import java.util.HashMap; ^ Line 0, column 0: could not parse error
message: error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/util/Stack.class). The major.minor version
'48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:19: Class java.util.Stack not found in import.
import java.util.Stack; ^ Line 0, column 0: could not parse error message:
error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/util/StringTokenizer.class). The major.minor
version '48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:20: Class java.util.StringTokenizer not found
in import. import java.util.StringTokenizer; ^ Line 0, column 0: could not
parse error message: error: Invalid class file format in
F:\jdk1.3.1\jre\lib\rt.jar(java/lang/Object.class). The major.minor version
'48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:0: Class java.lang.Object not found in class
org.apache.avalon.framework.logger.AbstractLoggable. ^ Line 0, column 0: 18
errors

sender com.mercalink.requestprocessor.MercalinkServlet

source Cocoon servlet

exception

org.apache.cocoon.ProcessingException: Language Exception:
org.apache.cocoon.components.language.LanguageException: Error compiling
sitemap_xmap:
Line 0, column 0: could not parse error message: error: Invalid class file
format in F:\jdk1.3.1\jre\lib\rt.jar(java/io/OutputStream.class).  The
major.minor version '48.0' is too recent for this tool to understand.
C:\tomcat\tomcat\work\Standalone\localhost\mercalink\cocoon-files\org\apache
\cocoon\www\sitemap_xmap.java:12: Class java.io.OutputStream not found in
import.
import java.io.OutputStream;
       ^

Is it possible to run Cocoon-2.0 with JDK-1.4?
Thanks
Niket




---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message