cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Costantino Sertorio" <costantino.serto...@swissonline.ch>
Subject Cannot access Cocoon WAP page
Date Mon, 09 Dec 2002 22:35:30 GMT
Hi,
I am having a problem while trying to access the sample hello.wml sample page of Cocoon (I
am running Apache Tomcat with Cocoon 2.0.3 on a Windows 2000 system) with a mobile phone.
The WAP browser waits a few seconds and then answers:
500: Web service problem:
Please contact service provider.
If I then select "Details", I read:
1500: Could not connect to site.

I have tried with a number of WAP emulators and it works perfectly; it also works if I save
the WML page and let the webserver serve it directly
(I also tried using different telecom providers with no success).

Is it possible that Cocoon refuses the User Agent when I access the page through a real mobile
device?
Anyone has any ideas of the reason why this behaviour can happen?

The log core.log reports the following:
REQUEST: /cocoon/hello.wml

CONTEXT PATH: /cocoon
SERVLET PATH: /hello.wml
PATH INFO: null

REMOTE HOST: 138.188.101.64
REMOTE ADDRESS: 138.188.101.64
REMOTE USER: null
REQUEST SESSION ID: null
REQUEST PREFERRED LOCALE: it
SERVER HOST: titao.homelinux.org
SERVER PORT: 8080

METHOD: GET
CONTENT LENGTH: -1
PROTOCOL: HTTP/1.1
SCHEME: http
AUTH TYPE: null

CURRENT ACTIVE REQUESTS: 1
REQUEST PARAMETERS:

HEADER PARAMETERS:

PARAM: 'host' VALUES: '[titao.homelinux.org:8080]'
PARAM: 'accept' VALUES: '[application/vnd.wap.wmlc;Type=4365, application/vnd.wap.wmlc;Type=4360,
application/vnd.wap.wmlc;Type=1108, application/vnd.wap.wmlc;Level=1.3, application/vnd.wap.wmlc,
application/vnd.wap.wmlscriptc, application/vnd.wap.multipart.related, application/vnd.wap.multipart.mixed,
application/x-up-device, application/vnd.phonecom.mmc-wbxml;Type=4364, application/vnd.phonecom.mmc-wbxml,
application/vnd.phonecom.im, application/octet-stream, application/vnd.openwave.pp, application/vnd.wap.sic,
application/vnd.wap.slc, application/vnd.wap.coc, application/vnd.uplanet.bearer-choice-wbxml,
application/vnd.uplanet.signal, application/vnd.uplanet.cacheop-wbxml, application/vnd.uplanet.alert-wbxml,
image/vnd.wap.wbmp, image/bmp, image/x-MS-bmp, audio/midi, audio/x-midi, audio/mid, text/x-vCalendar,
text/x-vCard, text/plain, application/x-mmc.wallpaper;type=image/bmp;size=2000;gray=1;w=101;h=64,
application/x-mmc.ringtone;type=audio/midi;size=2000;voices=1, application/x-mmc.title;charset=us-ascii;size=30,
image/bmp,image/vnd.wap.wbmp,application/vnd.uplanet.alert,application/x-up-alert,application/vnd.uplanet.bearer-choice,application/vnd.uplanet.cacheop,application/x-up-cacheop,application/vnd.phonecom.mmc-xml,text/x-wap.wml,text/vnd.wap.wml,text/x-hdml,text/html,text/vnd.wap.wmlscript,text/vnd.wap.co,text/vnd.wap.si,text/vnd.wap.sl,
*/*]'
PARAM: 'accept-charset' VALUES: '[utf-8, UTF-8, *]'
PARAM: 'accept-language' VALUES: '[it]'
PARAM: 'encoding-version' VALUES: '[1.3, 10 1.3]'
PARAM: 'user-agent' VALUES: '[SIE-ME45/23 UP.Browser/5.0.2.2 (GUI) UP.Link/5.1.1.4]'
PARAM: 'x-up-devcap-charset' VALUES: '[utf-8]'
PARAM: 'x-up-devcap-gui' VALUES: '[1]'
PARAM: 'x-up-devcap-iscolor' VALUES: '[0]'
PARAM: 'x-up-devcap-max-pdu' VALUES: '[2800]'
PARAM: 'x-up-devcap-numsoftkeys' VALUES: '[2]'
PARAM: 'x-up-uplink' VALUES: '[spwapgw1p.swissptt.ch]'
PARAM: 'x-up-wappush-secure' VALUES: '[www.openwave.com:9003/pap]'
PARAM: 'x-up-wappush-unsecure' VALUES: '[www.openwave.com:9002/pap]'
PARAM: 'connection' VALUES: '[close]'
-----------------
The following, instead, is the log of a (successful) connection with a WAP emulator:
REQUEST: /cocoon/hello.wml

CONTEXT PATH: /cocoon
SERVLET PATH: /hello.wml
PATH INFO: null

REMOTE HOST: AMS-CH-CSERTORI-N2HVI
REMOTE ADDRESS: 80.218.113.94
REMOTE USER: null
REQUEST SESSION ID: null
REQUEST PREFERRED LOCALE: de_CH
SERVER HOST: titao.homelinux.org
SERVER PORT: 80

METHOD: GET
CONTENT LENGTH: -1
PROTOCOL: HTTP/1.1
SCHEME: http
AUTH TYPE: null

CURRENT ACTIVE REQUESTS: 1
REQUEST PARAMETERS:

HEADER PARAMETERS:

PARAM: 'cache-control' VALUES: '[no-cache]'
PARAM: 'date' VALUES: '[Mon, 09 Dec 2002 23:29:15]'
PARAM: 'pragma' VALUES: '[no-cache]'
PARAM: 'accept-charset' VALUES: '[ISO-8859-1, UTF-8]'
PARAM: 'accept' VALUES: '[application/vnd.wap.wmlc, application/vnd.wap.wmlscriptc, image/vnd.wap.wbmp,
text/vnd.wap.wml, text/vnd.wap.wmlscript]'
PARAM: 'host' VALUES: '[titao.homelinux.org]'
PARAM: 'x-language' VALUES: '[en]'
PARAM: 'x-uniquewcid' VALUES: '[2779891191956766207]'
PARAM: 'user-agent' VALUES: '[YourWap Siemens SL45/2.63]'
PARAM: 'connection' VALUES: '[Keep-Alive]'


Any help would be greatly appreciated!

Costantino

Mime
View raw message