cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tiago Dias" <...@ptsoft.net>
Subject Cocoon 2.0.3 under JDK 1.4.1
Date Sun, 08 Dec 2002 13:57:21 GMT
Hi Josef,

  I think your problem is the same (at least similar) to the one I got when
tried to use Xalan 2.4.1 instead of the default 2.3.1 brought in the Cocoon
2.0.3 distribution. If you can try using Xalan version 2.3.1 instead and I
expect you won't have problems. Otherwise you'd need a Cocoon distribution
that supports Xalan 2.4.1 (has been recently included in the Cocoon
2.1-dev).

  Best regards,
  Tiago Dias

Quoting: "Franz-Josef Herpers"
-------------------------------
Hi,

since today I never had any problems installing Cocoon under Tomcat even
with JDK 1.4.

But now I have the following configuration:

Windows 2000 SP 3
Cocoon 2.0.3 for JDK 1.4
JDK 1.4.1
Tomcat 4.1.12
in the endorsed directory of JDK reside xalan.jar (Xalan 2.4.1) and the
Files
xercesImpl.jar (Xerces 2.2.0) and the dom.jar und sax.jar files (JAXP 1.2).

When I open the cocoon starting page i get the following error message:

message: Language Exception

description: org.apache.cocoon.ProcessingException: Language Exception:
org.apache.cocoon.components.language.LanguageException: Error compiling
sitemap_xmap:
Line 0, column 0: error: java.io.IOException: read error 1 error

The console shows:
java.lang.RuntimeException: org.apache.xml.utils.WrappedRuntimeException:
The ou
tput format must have a '{http://xml.apache.org/xalan}content-handler'
property!

I would appreciate any hint!

Thanks
Franz


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message