cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Holz <h...@fiz-chemie.de>
Subject Re: Trying to use PostgresSQL with Cocoon-2.0.2
Date Wed, 13 Nov 2002 20:33:25 GMT
Hi,

On Wednesday 13 November 2002 21:11, Simon Elbaz wrote:
> I am trying to use a PostgreSQL with Cocoon-2.0.2, JDK-1.4. I have
> downloaded the PostgreSQL driver pgjdbc2.jar for Java-1.4. The connection
> between Tomcat-4.0.3/postgresql  at the startings done (started the
> postgresql server with -i option).
>

> HttpProcessor[10500][4]/LogKitLogger: Could not return Connection
> java.lang.ClassCastException:
> org.apache.avalon.excalibur.datasource.Jdbc3Connection at
> org.apache.avalon.excalibur.datasource.ResourceLimitingJdbcConnectionPool.n
>ewPoolable(ResourceLimitingJdbcConnectionPool.java:81)

Looks like excalibur datasource expects a JDBC 3 driver.
Your driver supports JDBC2 only.

Try http://jdbc.postgresql.org/download/pg73b3jdbc1.jar
I did not yet tested it with cocoon, but it works fine with other
programs.

Martin

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message