cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessio Sangalli <ale...@manoweb.com>
Subject Re: Using Cocoon from the command
Date Mon, 11 Nov 2002 18:02:54 GMT

Ugo Cei wrote:

> It SHOULD be possible to just unpack the cocoon.war file from the binary
> distribution, cd to WEB-INF/lib and run:
>
>     java -jar cocoon-2.0.3.jar
>
> However, the Manifest in the JAR is wrong, since it contains:
>
> Class-Path: avalon-framework-4.1.2.jar avalon-excalibur-4.1.jar batik-
>  libs-1.1.1.jar bsf-2.2.jar fop-0.20.3rc.jar jakarta-regexp-1.2.jar js
>  tyle.jar logkit-1.0.1.jar rhino-1.5r3.jar xalan-2.3.1.jar xercesImpl-
>  2.0.0.jar xml-apis.jar xt-19991105.jar
>
> But the versions of the libraries are not those. For instance, it should
> be avalon-framework-20020627.jar instead.

I've tried to modify the MANIFEST file but at the end it didn't work the 
same. It's likely I'm not able to build a JAR, however it seems Cocoon 
can't be used from the command line right now out-of-the-box, am I wrong?

boh
ciao
as





---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message