cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hunsberger, Peter" <Peter.Hunsber...@stjude.org>
Subject RE: Why is my cocoon app an IE6 killer?
Date Fri, 04 Oct 2002 16:13:30 GMT
> When accessing a
> - servlet generated site
> - with (lots of) images
> - using a recent versions of Internet Explorer (i.e.6) on windows
> then IE stops loading images. And even better: from this moment on it 
> generally
> doesn’t display images anymore, even from other sites until you restart 
> IE.

I can confirm that you've still got the problem with IE 6 and SP1...

Though you don't explicitly state it, it sounds like if the same page is
servered as static HTML it renders properly?  If so, it's just a guess, but
one possibility would be that there's a difference in the HTTP handling.
Perhaps the servlet engines are negotiating HTTP 1.0 vs. 1.1 for static
pages or vice versa?  In such a case perhaps the servlet engine has a bug
and doesn't close the image streams exhausting some resource on IE?  Or
similarly, perhaps it's an IE bug of the same type.

It seems to me the first place to look would be to see what the HTTP headers
have to say, though you may have to get pretty low level to see what the
differences might be. 


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message