cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kjetil Kjernsmo <kje...@kjernsmo.net>
Subject Re: Installing the mail component
Date Fri, 18 Oct 2002 22:42:05 GMT
On Friday 18 October 2002 15:22, Geoff Howard wrote:
> Disclaimer: I am not in the least familiar with the
> mail component that you are trying to install.  I'm
> just looking at your general situation of trying to
> debug roles configuration at startup.

Yeah, but that's OK! (that's a much longer disclaimer than "IANAL"... 
:-) )

> It may have - try stopping your servlet engine,
> deleting the work directory and restarting.  This
> shouldn't be necessary, but sometimes it is currently.

Mmmmkay. I did more than that: I removed the whole cocoon installation, 
removed all my current experiements, installed and unzipped a 
cocoon.war I compiled from a fresh CVS a couple of days ago, and 
deleted /usr/share/tomcat4/work which is where I think my Debian Woody 
distro has the tomcat work directory. Then, I confirmed that the new 
cocoon installation "worked", before stopping Tomcat again, deleting 
the work directory again, restarting Tomcat, modify cocoon.xconf and 
reinstall myroles.xconf, and then.... No... :-( Same error.

> > I am now quite confident that myroles.xconf is
> > loaded, because if I drop
> > WEB-INF/ from it's path, it complains explicitly
> > that it isn't found,
> > which should mean that it is found when I include
> > WEB-INF/ .
>
> Well, that only tells you that myroles.xconf is found
> and it's trying to load.  

Right.

> The first error below
> explicitly says that it didn't load: Error trying to
> load user-roles configuration

Yep.

> > I get another error message now that I didn't see
> > before.
> >
> > ERROR   (2002-10-18) 11:59.20:465   [access]
> > (Unknown-URI)
> > Unknown-thread/CocoonServlet: Exception reloading
>
> org.apache.avalon.framework.configuration.ConfigurationException:
> > Error
> > trying to load user-roles configuration
>
> I'd double check your myroles.xconf for typos :) etc.

ntuple-checked it now.... :-) 

> You may also want to check the archives for recent
> problems loading user roles - it may be that the basic
> mechanism isn't working?  Haven't done it in a while.

I couldn't find anything on the topic. Lots of stuff about roles in the 
Authentication Framework though.

> This next FileNotFound may be a misleading error
> message - it may be that the failure to load condition
> above is later on in the code incorrectly assumed to
> be identical to FileNotFound.

Yeah. Those Java error messages are often hard to interprete... 

> > BTW, how is cocoon supposed to find the mail.jar?
> > From the shorthand
> > name and the fact that it is in WEB-INF/lib only? I
> > haven't told it
> > anything other than that...?
>
> Unless I misunderstand the issue, it's not looking for
> mail.jar - it just places all jars in /lib on the
> classpath at startup and then it will be able to find
> any package names it needs there, along with other
> jars.

OK, so that shouldn't be a concern. How do I figure out what classes are 
in the classpath, BTW? (I guess this is something I ought to know, I've 
got "Learning Java" in my office, but I haven't been there for a while, 
due to that I've got a new apartment that needs a lot of work).

>  If it's not too long, can you copy mroles.xconf
> here?

Where? Right here? This is it:

<?xml version="1.0"?>
<role-list>
  <role name="cxa.component.mail.MailComponent"
	shorthand="mail"
	default-class="cxa.component.mail.MailComponentImpl"/>
</role-list>

BTW, I found that on the CD from the book, the directory was indeed 
named with "components", but obviously, it is not meant to be run from 
there, so it probably doesn't mean anything.

> Obviously the comment was not updated since xconf was
> moved, but that isn't the problem.

OK. Well, here's the patch... :-) :
7c7
<      - webapp/cocoon.xconf (this file) - describes each core component
---
>      - webapp/WEB-INF/cocoon.xconf (this file) - describes each core 
component


>  The basic idea
> though that the mail component isn't working correctly
> with 2.1 dev is a very likely possibility.  Isn't the
> book based on 2.0.3?

Mmmm, yes, at least the 2.0 series. I think it is hard to envision that 
any new stuff in 2.1 would have that much of an impact on this 
component. It looks quite straightforward... Then it would rather be 
something from Avalon, specifically, it implements the 
"Parameterizable" interface. Has there been big things there?
Wonder if Matthew reads this....?

Best,

Kjetil
-- 
Kjetil Kjernsmo
Astrophysicist/IT Consultant/Skeptic/Ski-orienteer/Orienteer/Mountaineer
kjetil@kjernsmo.net  webmaster@skepsis.no  editor@learn-orienteering.org
Homepage: http://www.kjetil.kjernsmo.net/


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message