cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kjetil Kjernsmo <kje...@kjernsmo.net>
Subject Installing the mail component
Date Thu, 17 Oct 2002 21:58:16 GMT
Hi List!

I'm trying to get the Mail component from Matthew and Carsten's book 
installed, but I can't get it right. The problem seems to be that 
Cocoon can't find my myroles.xconf and thus it stops with a "Cocoon was 
not initialized."-message. 

I have cocoon.xconf and myroles.xconf in 
$TOMCAT_HOME/webapps/cocoon/WEB-INF

After consulting the FAQ, my cocoon.xconf root element looks like this:
<cocoon version="2.0" user-roles="WEB-INF/myroles.xconf">
First, I didn't have the WEB-INF/ part there, because cocoon.xconf is 
there too, and I assumed that if they both were in the same dir, there 
would be no problem. Then, I have moved myroles.xconf around, created 
symlinks to and from everywhere. For every change, I've restarted 
Tomcat. Yet, I see messages like 

ERROR   (2002-10-17) 23:35.44:746   [core] (Unknown-URI) 
Unknown-thread/Cocoon: Could not configure Cocoon environment with user 
roles file
java.io.FileNotFoundException
	at 
org.apache.naming.resources.DirContextURLConnection.getInputStream(DirContextURLConnection.java:344)

So, it seems like it doesn't find my myroles.xconf, but with the many 
places I've tried to put it or link it, that sounds strange. Can there 
really be a place I haven't thought of...?

I've been wondering if it is something else that it doesn't find. 
mail.jar is in $TOMCAT_HOME/webapps/cocoon/WEB-INF/lib
, the two MailComponent* files are in 
$TOMCAT_HOME/webapps/cocoon/WEB-INF/classes/cxa/components/mail
(all these things are copied unedited right from the CD to the server) 
and myroles.xconf looks like this:

<?xml version="1.0"?>
<role-list>
  <role name="cxa.component.mail.MailComponent"
	shorthand="mail"
	default-class="cxa.component.mail.MailComponentImpl"/>
</role-list>

I've been staring at those six lines for the last four hours, just in 
case there was something there I didn't understand, or if it was 
something as trivial as typo somewhere... I haven't put the 
transformers anywhere, but they're not involved at this point...?

I think my brain is about to blow up, can anybody save it...? :-)

Best,

Kjetil


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message