cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Gritsenko <vadim.gritse...@verizon.net>
Subject Re: Encoding problem
Date Wed, 18 Sep 2002 12:27:55 GMT
Alex Romayev wrote:

>Let me be more specific and also simplify the example:
>
...

>Does not work:
>
><xsl:param name="city" select="'Äåëè'"/>
>

Are these funny characters above in UTF-8? Does your XSL has 
encoding="UTF-8" on the top?


>...
>
><a href="city-detail="$city"><xsl:value-of
>select="$city"/></a>
>
>After transformation I get:
><a
>href="city-detail=%D0%94%D0%B5%D0%BB%D0%B8">Äåëè</a>
>

What's serializer configuration? Does it have proper encoding set?

Vadim



>--- Alex Romayev <romayev@yahoo.com> wrote:
>  
>
>>Hello,
>>
>>I'm having what seems to be an encoding problem --
>>not
>>sure it's related to Cocoon, but... ;)
>>
>><xsl:for-each select="//city-name">
>> <a href="city-detail?city-name={.}"><xsl:value-of
>>select="."/></a><br/>
>></xsl:for-each>
>>
>>All my xml is UTF-8, it work in English, but not in
>>Russian.  Any ideas?
>>
>>Thanks,
>>-Alex
>>    
>>


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message