cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cumming...@netscape.net (Steven Cummings)
Subject Re: Problem redirecting to an XSP
Date Mon, 23 Sep 2002 15:18:10 GMT
Antonio,

I discovered that my problem, very strangely enough was some misplaced jars. What confused
the heck out of me is why I didn't get an exception (on the browser page and/or in the logs:
there was none) and just a blank page. As for your problem, the only thing I can note is that
you redirect to {resource:url} on authentication and on reading the documentation it tells
me that the parameter passed by the authentciation framework is called 'resource', so it should
be <map:redirec-to uri="{request:resource}".

/S

Antonio Gallardo Rivera <agallardo@agsoftware.dnsalias.com> wrote:

>I will try to explain the same error as yours.
>
>Have you checking if the authentication manager is getting the right
>parameters?
>
>1-I am now getting this:
>
>DEBUG   (2002-09-23) 03:19.57:700   [core.manager] (/myapp/my-login)
>Thread-6/ResourceLimitingPool: Got a
>org.apache.cocoon.webapps.authentication.components.AuthenticationManager
>from the pool.
>DEBUG   (2002-09-23) 03:19.57:700   [core.roles] (/myapps/my-login)
>Thread-6/DefaultRoleManager: looking up shorthand authentication-manager,
>returning
>org.apache.cocoon.webapps.authentication.components.AuthenticationManager
>DEBUG   (2002-09-23) 03:19.57:701   [core.authentication-manager]
>(/multipremios/ags-login) Thread-6/AuthenticationManager: BEGIN authenticate
>handler=myhandler, parameters=SourceParameters: {password = (), name = ()}
>                                                                          ^^^^
>2-The sitemap is not "serving" the params as requested, see the fragment of my
>sitemap:
>
><map:match pattern="ags-login">
>        <map:act type="auth-login">
>            <map:parameter name="handler" value="agshandler"/>
>            <map:parameter name="parameter_name"
>        value="{request:name}"/>
>            <map:parameter name="parameter_password"
>        value="{request:password}"/>
>            <map:redirect-to uri="{request:url}"/>
>        </map:act>
>    <!-- An error ocurred -->
>        <map:generate src="docs/aut-error.xsp" type="serverpages"/>
>        <map:transform src="stylesheets/thestyle.xsl"/>
>        <map:transform type="encodeURL"/>
>        <map:serialize/>
>      </map:match>
>
>3-I also check and the caller is serving the params as follow (from core.log):
>
>REQUEST PARAMETERS:
>
>PARAM: 'password' VALUES: '[mypass]'
>PARAM: 'name' VALUES: '[myname]'
>
>4-What I am doing wrong?
>
>Thanks in advance,
>
>Antonio Gallardo
>
>El Viernes, 20 de Septiembre de 2002 16:09, Steven Cummings escribió:
>> Hello,
>>
>> I have what *seems* to be a problem redirecting to an XSP after
>> authentication. At first I was trying out the sunRise components per
>> Matthew's tutorial and it seems to work until my login component in the
>> pipeline is called, and the authentication pipeline configured in the
>> handler is called. When this occurs I get a blank page and NO error
>> message. I looked at my log files and it appears that the login pipeline
>> uses the sunRise config to call my authentication component, which happens
>> to be an XSP and then it just kind of stops. I don't see any error messages
>> in the log, and the page returned is blank.
>>
>> Then I tried the same situation with my own custom authentication
>> components (having NOTHING to do with sunRise), just my own set of actions
>> and sitemap flow-control. Again, all was fine and well until a redirect to
>> my authenticate.xsp was made, and a blank page was returned and no
>> information in the log file. This seems really wierd to me. My XSP does do
>> work, and I would figure that some exception would be thrown at the very
>> least. Does this problem sound familiar to anyone? I couldn't find this
>> problem in the mailing list archives. Thanks ahead of time for any help
>> anyone can provide.
>>
>> /S
>
>---------------------------------------------------------------------
>Please check that your question  has not already been answered in the
>FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
>
>To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
>For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
>
>


-- 
Steven Cummings
Columbia, MO
Email: cummingscs@netscape.net
AIM:   cummingscs
ICQ:   3330114


__________________________________________________________________
The NEW Netscape 7.0 browser is now available. Upgrade now! http://channels.netscape.com/ns/browsers/download.jsp


Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message