cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From apurva zaveri <azav...@yahoo.com>
Subject jndi, oracle, generator
Date Sat, 28 Sep 2002 18:25:21 GMT
hello,

I have a wierd problem. I am almost about to kill
myself for this.
It would seem this has nothing to with cocoon but it
has.



   String ln = "jdbc/db";
   Hashtable env = new Hashtable (5);
   env.put (Context.INITIAL_CONTEXT_FACTORY,
            
"com.sun.jndi.fscontext.RefFSContextFactory");
   env.put (Context.PROVIDER_URL, "file:/rertn/JNDI");
   ctx = new InitialContext(env);
   OracleOCIConnectionPool cpool = new
OracleOCIConnectionPool("apurva","apffapz",
"jdbc:oracle:oci:@RERTNDB", null);
   ctx.unbind(ln);
   ctx.bind (ln,cpool);


This is a snippet of code from a java file that i use
to bind a OracleOCIConnectionPool obj with JNDI. In
the
same class i also do a look up like this:

    OracleOCIConnectionPool cpool =
(OracleOCIConnectionPool) ctx.lookup (ln);
    OracleOCIConnection conn = (OracleOCIConnection)
cpool.getConnection();


works fine. I used this lookup code from the cocoon
generator for months not a problem. Everything 
worked fine. 
It is a windows 2000 server with oracle 9i DB.
Tomcat,cocoon,oracle on the same server.

I uninstalled oracle 9i and installed oracle 9i second
release. Since orcale did not let me
keep the same oracle instance name, I changed the
instance name from "rertn" to "rertndb".
I made the obcious changes like

   env.put (Context.PROVIDER_URL,
"file:/rertndb/JNDI"); in binding.

I compiled the application and none of the generator
works anymore. I almost got a stroke for a moment
nothing in the application works. What is wierd is
that the class file which does the binbing,
as you know also has a look-up, the look-up for the
obj works there and i can fire queries. So it seems
there is nuthing wrong with the OCI driver.

When i say the generator do not work means: it stops
excecution at 

    OracleOCIConnectionPool cpool =
(OracleOCIConnectionPool) ctx.lookup (ln);
 throws no exception.

I tried to do a look-up from an independent jsp page.
No exception in caught but the page shows

java.lang.UnsatisfiedLinkError: make_c_state error.
(which is runtime i believe)

HELP!

-Apurva Zaveri








__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message