cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo Rivera <agalla...@agsoftware.dnsalias.com>
Subject Re: [C 2.1] Problem in auth-framework
Date Mon, 23 Sep 2002 02:43:20 GMT
I saw the problem is that is not resolving the parameters in the sitemap. But 
the params are in the request. Please help.

      <map:match pattern="my-login">
        <map:act type="auth-login">
            <map:parameter name="handler" value="myhandler"/>
            <map:parameter name="parameter_name" value="{request:name}"/>
            <map:parameter name="parameter_password" 
value="{request:password}"/>
<!--                                              ^^^^^^^^^^^^^^^^^^^^ -->
<!--						This parameters is not working.  -->
            <map:redirect-to uri="{request:url}"/>
        </map:act>
        <!-- Fallo la autenticación, presenta página de error -->
        <map:generate src="docs/aut-error.xsp" type="serverpages"/>
        <map:transform src="stylesheets/mystylesheet.xsl"/>
        <map:transform type="encodeURL"/>
        <map:serialize/>
      </map:match>

Antonio Gallardo


El Domingo, 22 de Septiembre de 2002 16:37, Antonio Gallardo Rivera escribió:
> I am using the lastes CVS and since yesterday the auth error is not
> working. I see that the paramaters are not going to the my-checkuser in the
> sitemap:
>
> <map:match pattern="ags-checkuser">
>         <map:generate src="docs/ags-users.xsp" type="serverpages"/>
>         <map:transform src="stylesheets/ags-users.xsl">
>             <map:parameter name="use-request-parameters" value="true"/>
>         </map:transform>
>         <map:serialize type="xml"/>
>       </map:match>
>
> Also it works before. And I dont touched it. In the log core.log I see:
>
> .......
> REQUEST: /myapp/my-login
>
> CONTEXT PATH: /myapp
> SERVLET PATH: /my-login
> PATH INFO: null
>
> REMOTE HOST: localhost
> REMOTE ADDRESS: 127.0.0.1
> REMOTE USER: null
> REQUEST SESSION ID: null
> REQUEST PREFERRED LOCALE: es
> SERVER HOST: localhost
> SERVER PORT: 8080
>
> METHOD: POST
> CONTENT LENGTH: 27
> PROTOCOL: HTTP/1.1
> SCHEME: http
> AUTH TYPE: null
>
> CURRENT ACTIVE REQUESTS: 1
> REQUEST PARAMETERS:
>
> PARAM: 'password' VALUES: '[mypass]'
> PARAM: 'name' VALUES: '[myname]'
> HEADER PARAMETERS:
>
> PARAM: 'user-agent' VALUES: '[Mozilla/5.0 (compatible; Konqueror/3; Linux;
> X11; i686)]'
> PARAM: 'referer' VALUES: '[http://localhost:8080/myapp/aut-inicio]'
> PARAM: 'pragma' VALUES: '[no-cache]'
> PARAM: 'cache-control' VALUES: '[no-cache]'
> PARAM: 'accept' VALUES: '[text/*, image/jpeg, image/png, image/*, */*]'
> PARAM: 'accept-encoding' VALUES: '[x-gzip, gzip, identity]'
> PARAM: 'accept-charset' VALUES: '[iso-8859-1, utf-8;q=0.5, *;q=0.5]'
> PARAM: 'accept-language' VALUES: '[es]'
> PARAM: 'host' VALUES: '[localhost:8080]'
> PARAM: 'content-type' VALUES: '[application/x-www-form-urlencoded]'
> PARAM: 'content-length' VALUES: '[27]'
>
> SESSION ATTRIBUTES:
>
>
> DEBUG   (2002-09-22) 22:19.50:591   [core.manager] (/myapp/my-login)
> Thread-10/ResourceLimitingPool: Got a
> org.apache.cocoon.webapps.authentication.components.AuthenticationManager
> from the pool.
> DEBUG   (2002-09-22) 22:19.50:592   [core.roles] (/myapp/my-login)
> Thread-10/DefaultRoleManager: looking up shorthand authentication-manager,
> returning
> org.apache.cocoon.webapps.authentication.components.AuthenticationManager
> DEBUG   (2002-09-22) 22:19.50:592   [core.authentication-manager]
> (/myapp/my-login) Thread-10/AuthenticationManager: BEGIN authenticate
> handler=myhandler, parameters=SourceParameters: {password = (), name = ()}
>
> As you can see here he dont send correctly the parameters to the
> auth-action. I looks like it lossed the params!
>
> ... and continue:
>
> INFO    (2002-09-22) 22:19.50:592   [core.authentication-manager]
> (/myapp/my-login) Thread-10/AuthenticationManager: AuthenticationManager:
> Trying to authenticate using handler 'myhandler'
> DEBUG   (2002-09-22) 22:19.50:592   [core.authentication-manager]
> (/myapp/my-login) Thread-10/AuthenticationManager: start authentication
> DEBUG   (2002-09-22) 22:19.50:592   [core.authentication-manager]
> (/myapp/my-login) Thread-10/AuthenticationManager: start invoking auth
> resource
> DEBUG   (2002-09-22) 22:19.50:593   [core.manager] (/myapp/my-login)
> Thread-10/ResourceLimitingPool: Got a
> org.apache.cocoon.webapps.session.connector.ResourceConnectorImpl from the
> pool.
> DEBUG   (2002-09-22) 22:19.50:593   [core.manager] (/myapp/my-login)
> Thread-10/ResourceConnectorImpl: start loading 'cocoon:raw://my-checkuser'
> DEBUG   (2002-09-22) 22:19.50:593   [core.manager] (/myapp/my-login)
> Thread-10/ResourceConnectorImpl: BEGIN loadXMLFromURI
> uri=cocoon:raw://my-checkuser, typeParams=null,
> parameters=SourceParameters: {password = (), name = ()}
>
> Please help me:
>
> Regards,
>
> Antonio Gallardo
>
> ---------------------------------------------------------------------
> Please check that your question  has not already been answered in the
> FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
>
> To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message