cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Luzyanin <i...@ProZa.Lviv.UA>
Subject Re: Sendmail again :(
Date Fri, 20 Sep 2002 06:16:38 GMT
On Wednesday 18 September 2002 15:33, Ivan Luzyanin wrote:
> Hi!
>
> I'm having a problem with sendmail. I've successfuly set up sendmail
> logicsheet, put mail.jar from JavaMail 1.3 pakage to WEB-INF/lib.
> Transformed XSP page (Java source in work dir, attached) seemes to be ok
> and no errors reported in log-file...
> But still i can't recieve an e-mail, and most strange thing is that result
> of pipeline execution is empty document... I try to apply not valid e-mail
> address and still the same result  - no result (empty document).
>
>
> Desired result:
> <page>
> <upsa>UPSA</upsa>
> </page>
>
> and an e-mail message in my inbox :)
>
> My XSP:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <xsp:page
>  language="java"
>  xmlns:xsp="http://apache.org/xsp"
>  xmlns:xsp-request="http://apache.org/xsp/request/2.0"
>  xmlns:sendmail="http://apache.org/cocoon/sendmail/1.0" >
>  <page>
>   <xsp:logic>
>    String text =
>    "Hi,\n"+
>    "this mail has been send through a web form ...\n";
>   </xsp:logic>
>   <sendmail:send-mail>
>    <sendmail:charset>ISO-8859-1</sendmail:charset>
>    <sendmail:from>luzyanin@hotmail.com</sendmail:from>
>    <sendmail:to>ivan@proza.lviv.ua</sendmail:to>
>    <sendmail:subject>Cocoon send mail test</sendmail:subject>
>    <!-- Modify the next line to point to your mail server -->
>    <sendmail:smtphost>192.168.0.3</sendmail:smtphost>
>    <sendmail:body>
>     <xsp:expr>text</xsp:expr>
>    </sendmail:body>
>   </sendmail:send-mail>
>   <upsa>UPSA</upsa>
>  </page>
> </xsp:page>
>
> Sitemap pipeline:
> <map:match pattern="mail.xml">
>      <map:generate src="docs/mail.xsp" type="serverpages"/>
>       <map:serialize type="xml"/>
> </map:match>
>
> Snip from sitemap logfile:
>
> DEBUG   (2002-09-18) 15:12.29:482   [sitemap] (/proza-new/mail.xml)
> HttpProcessor[8080][4]/sitemap_xmap: Matched wildcard pattern *.xml
> DEBUG   (2002-09-18) 15:12.29:483   [sitemap] (/proza-new/mail.xml)
> HttpProcessor[8080][4]/AbstractSitemap:
> Current Sitemap Parameters:
> PARAM: '1' VALUE: 'mail'
> PARAM: '0' VALUE: 'mail.xml'
>
> DEBUG   (2002-09-18) 15:12.29:483   [sitemap.selector.request-parameter]
> (/proza-new/mail.xml) HttpProcessor[8080][4]/RequestParameterSelector:
> Request parameter 'action' not set -- failing.
> DEBUG   (2002-09-18) 15:12.29:484   [sitemap] (/proza-new/mail.xml)
> HttpProcessor[8080][4]/sitemap_xmap: Matched wildcard pattern mail.xml
> DEBUG   (2002-09-18) 15:12.29:485   [sitemap] (/proza-new/mail.xml)
> HttpProcessor[8080][4]/AbstractSitemap:
> Current Sitemap Parameters:
> PARAM: '0' VALUE: 'mail.xml'
> PARAM: '../1' VALUE: 'mail'
> PARAM: '../0' VALUE: 'mail.xml'
>
> DEBUG   (2002-09-18) 15:12.29:485   [sitemap] (/proza-new/mail.xml)
> HttpProcessor[8080][4]/sitemap_xmap: Component
> generator:serverpages(Parameters.EMPTY_PARAMETERS)
> DEBUG   (2002-09-18) 15:12.29:486   [sitemap] (/proza-new/mail.xmll)
> HttpProcessor[8080][4]/sitemap_xmap: Source= docs/mail.xsp
> DEBUG   (2002-09-18) 15:12.29:487   [sitemap] (/proza-new/mail.xml)
> HttpProcessor[8080][4]/sitemap_xmap: Component
> serializer:xml(Parameters.EMPTY_PARAMETERS)
>
> Help me, please! I've killed 2 hours to find out where is the problem...
>
> My env: Cocoon 2.0.3, Tomcat 4.0.4, JDK 1.4.0_01, SuSE 8.0
>
> Ivan Luzyanin.


I found where was a problem. I forget to put activation.jar from JAF package. 
Now it works fine.

Regards!
Ivan Luzyanin.

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message