cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barbara Post" <bab...@ifrance.com>
Subject Re: CVS build -> missing WEB-INF/lib !
Date Tue, 03 Sep 2002 14:56:42 GMT
ah, I used -Dinclude.webapp.libs=yes webapp instead... guess I was on the
wrong page. Will rebuild then.

Yes my JAVA_HOME is jdk1.3.1.

Your site is great with my other questions :
http://ziegeler.bei.t-online.de/c2auth.html

 :-) Thanks.
----- Original Message -----
From: "Carsten Ziegeler" <cziegeler@s-und-n.de>
To: <cocoon-users@xml.apache.org>
Sent: Tuesday, September 03, 2002 4:56 PM
Subject: RE: CVS build -> missing WEB-INF/lib !


>
>
> > -----Original Message-----
> > From: Barbara Post [mailto:babs33@ifrance.com]
> > Sent: Tuesday, September 03, 2002 4:47 PM
> > To: cocoon-users@xml.apache.org
> > Subject: Re: CVS build -> missing WEB-INF/lib !
> >
> >
> > Precision : no jar in the war. ok, I copy all the jars to the right
place
> > and Tomcat says it's ok now excepted :
> Did you specify the -Dinclude.webapp.libs=true option when building?
> >
> > org.apache.avalon.framework.configuration.ConfigurationException:
> > Cannot get
> > component selector for 'serialize' at
> > jndi:/localhost/cocoon/sitemap.xmap:386:31
> >
> Do you use the same environment for building and running (same JDK)?
>
> > So I comment the <views/> part and cocoon's welcome page shows up...
> >
> > ok, now where is the link to sunspot demo portal in this 2.1 version ?
;-)
> It's on the welcome page (cocoon/samples/welcome) in the right column
> at the bottom. (or you can invoke (cocoon/samples/portal/ )
>
> Carstne
>
> >
> > Babs
> > ----- Original Message -----
> > From: "Barbara Post" <babs33@ifrance.com>
> > To: <cocoon-users@xml.apache.org>
> > Sent: Tuesday, September 03, 2002 4:36 PM
> > Subject: CVS build -> missing WEB-INF/lib !
> >
> >
> > > I use T 2.0.4 and jdk 1.3.1, wanted to use latest c2.1 war
> > (from one hour
> > > ago cvs head). Tomcat strangely didn't unpack, and when I
> > manually unpack
> > it
> > > says :
> > >
> > >  The requested service (Servlet Cocoon2 is currently unavailable) is
not
> > > currently available.
> > >
> > > When I built cocoon it told it was targeted for jvm 1.2 so 1.3.1
should
> > > work...
> > >
> > > What can be wrong ? The log says :
> > >
> > > java.lang.ClassNotFoundException:
> > org.apache.cocoon.servlet.CocoonServlet
> > >  at
> > >
> > org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClass
> > Loader.jav
> > > a:1406)
> > >  at
> > >
> > org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClass
> > Loader.jav
> > > a:1254)
> > >
> > > Ah well, "lib" subdirectory of WEB-INF is missing, argh...
> > >
> > > Strange... I used build.bat -Dinclude.webapp.libs=yes webapp
> > >
> > > ----- Original Message -----



---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message