cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nika Jones <njo...@fredesign.com>
Subject Cocoon Won't Parce
Date Thu, 01 Aug 2002 16:48:09 GMT

-- 
Hello:

I've been looking through the archives and I can't quite seem to find 
my problem. Which is...

I go to http://localhost/cocoon and the directory contents are 
displayed... They are formatted and broken down into "subdirectories" 
and "files".

Does anyone know why they are not being run through a stylesheet?? I 
click on the sitemap.xmap and I get XML output. I go into the 
WEB-INF/cocoon.xconf and I get an error that says I don't have 
permission to access the file!?

Also I have to run /cocoon from my web directory and not the 
java/jakarta/webapps/cocoon ? this happend after I added the line:

	JKMount /cocoon/* ajp12

to my httpd.conf file (Perviously I was only getting a directory listing...)

I have all of the xalan, xml-apis, and such files in the 
cocoon/WEB-INF/lib folder

and the permissions of the files in the cocoon/WEB-INF/ folder are 
all set correctly!

Does anyone have a clue... can I try any commandline options to make 
sure that all is working?

I've tried:

	java org.apache.xalan.xslt.Process -in fooX.xml
	-xsl foo.xsl -out my.htm

in my xalan/samples folder, but I get an error:

	Exception in thread "main" java.lang.NoClassDefFoundError:
	org/apache/xalan/xslt /Process

?????
I'm pretty new at java, so I think I have all of the .jars in the 
correct place?!

well I'm using:

Cobalt Raq4
Linux
Cocoon 2.0.3
Tomcat 3.2.3
Java jdk 1.3.1

Thanks for nay help!

Nika


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message