cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Albert Cervera Areny" <informa...@sedifa.com>
Subject Yet another No suitable driver error
Date Thu, 08 Aug 2002 12:15:11 GMT
I get the following error while trying to connect to a postgresql database
throw the SQLTransformer:

java.sql.SQLException: No suitable driver

I've seen in the list archives that it's been reported various times but
none of the solutions seems to correct my problem.

web.xml:

  <init-param>
    <param-name>load-class</param-name>
    <param-value>
      org.postgresql.Driver
    </param-value>
  </init-param>
  <init-param>
    <param-name>extra-classpath</param-name>
    <param-value>/usr/share/java/postgresql.jar</param-value>
  </init-param>

cocoon.xconf:

<datasources>
     <jdbc logger="core.datasources.postgres" name="cocoon">
            <pool-controller max="10" min="5"/>
            <driver>org.postgresql.Driver</driver>
            <dburl>jdbc:postgresql://localhost/cocoon:5432</dburl>
            <user>cocoon</user>
            <password>password</password>
     </jdbc>
</datasources>

I don't know if org.postgresql.Driver is necessari in both files but I
started I've tried it in just one of them and doesn't work neighter.
Of course access to the database is enabled correctly, the port is 5432 as
NMAP says ;) and I can connect from psql. All connection data seems to be
correct... Any other ideas??


Thanks!

Albert Cervera Areny




---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message