cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: xpath queries not working in xmldb
Date Sun, 04 Aug 2002 04:32:05 GMT
> From: John Moylan [mailto:johnm@rte.ie]
> 
> Hi,

Hi John,
 
> Are there issues I should be aware of when using the xmldb using
xindice
> from the command line to return documents using:
> xindice xpath_query -c /db/extractsdb -q
>
"//Metadata/Property[@FormalName='PublicationDate'][@Value='20020710']"
> the result I get is all files published on the 20020710
> 
> But, when I use the following in cocoon:
>
http://localhost:8080/cocoon/xmldb/extractsdb/?xpath=//Metadata/Property
[@Form
> alName='PublicationDate'][@Value='20020710']
> the result I get is for all files in the collection.
> 
> Does Cocoon's XMLDB transformer have problems with attributes?

No. But all proxies/web browsers/web servers/etc are really upset with
your invalid URL. Please do encode at least all '=' characters properly.

Here is URL to URL RFC for your convenience:
http://www.w3.org/Addressing/rfc1738.txt
(See chapter "2.2. URL Character Encoding Issues", paragraph "Unsafe:")


Regards,
Vadim


> John



---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message