cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: "...Parser does not implement XML Reader"
Date Sun, 11 Aug 2002 18:23:40 GMT
> From: Lauren Commons [mailto:lhcommons@yahoo.com]
> 
> First of all, I know this question has been covered,
> but none of the list archives are available, so I'll
> ask again...
> I am running RH7.(2 I think?), JDK1.4, Tomcat
> 4.0.3-LE-jdk14.
> I had previously installed (unsuccesfully) cocoon
> 2.0.2.  I had had the standard problems people have
> with the jdk14 installation (mismatched parser
> versions, etc.).  I never did get that working...
> I just downloaded and installed the binary
> cocoon-2.0.3 for jdk1.4.  First of all, I assume that
> the install html pages are obsolete since they
> indicate that no inaries exist for jdk1.4.  So I
> referred to the INSTALL doc in the distribution tar.gz
> file, which suggests removing jaxp and parser jars
> from tomcat/lib and puting xerces in there (renamed
> parser.jar) (and I've removed the work directory...).
> When I restart Tomcat and browse /cocoon/ I get the
> dreaded classcast exception "SAX 2... Parser does not
> implement XML Reader".

Classloading issue.


> Any suggestions?

The easiest way to do this cleanly and with less amount of hassle is to
upgrade to Tomcat 4.0.4, in your case it is LE.

If you don't want to go this route, combine all advices regarding JDK1.4
+ Parsers and Tomcat 4.0.3 + Cocoon, it won't be easy but it is possible
to make this work. Don't remember details though - I'm happy with 4.0.4

Vadim



---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message