cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barbara Post" <bab...@ifrance.com>
Subject Re: weird ? (sunshine, c203)
Date Tue, 20 Aug 2002 11:50:35 GMT
My namespace is : "http://sunshine.sunde.sunshine/1.0" and I use Xalan
2.3.1, Xerces 2.0.2.

I am sure that I can use context without sunrise authentication, am I wrong
? (anyway in the full app I use authentication). Transformer works well for
getxml context="sunRise", but not my custom context...

xsl does :

<xsl:template match="/">
<sunshine:createcontext name="MyContext"/>
<sunshine:setxml context="MyContext" path="/root/lkfmPageTitle">
test</sunshine:setxml>
<sunshine:getxml context="MyContext" path="/root/lkfmPageTitle"/>
</xsl:template>


Logs shows :

[setup] ---------------------------- [Tue Aug 20 13:44:22 CEST
2002] ----------------------------
[startDocument]
[startPrefixMapping] prefix=sunshine,uri=http://sunshine.sunde.sunshine/1.0
[startElement]
uri=http://sunshine.sunde.sunshine/1.0,local=createcontext,raw=sunshine:crea
tecontext
[            ] 1.
uri=http://www.w3.org/2000/xmlns/,local=sunshine,qname=xmlns:sunshine,type=C
DATA,value=http://sunshine.sunde.sunshine/1.0
[            ] 2. uri=,local=name,qname=name,type=CDATA,value=MyContext
[endElement]
uri=http://sunshine.sunde.sunshine/1.0,local=createcontext,qname=sunshine:cr
eatecontext
[endPrefixMapping] prefix=sunshine
[startPrefixMapping] prefix=sunshine,uri=http://sunshine.sunde.sunshine/1.0
[startElement]
uri=http://sunshine.sunde.sunshine/1.0,local=setxml,raw=sunshine:setxml
[            ] 1.
uri=http://www.w3.org/2000/xmlns/,local=sunshine,qname=xmlns:sunshine,type=C
DATA,value=http://sunshine.sunde.sunshine/1.0
[            ] 2.
uri=,local=path,qname=path,type=CDATA,value=/root/lkfmPageTitle
[            ] 3.
uri=,local=context,qname=context,type=CDATA,value=MyContext
[characters]
test
[endElement]
uri=http://sunshine.sunde.sunshine/1.0,local=setxml,qname=sunshine:setxml
[endPrefixMapping] prefix=sunshine
[startPrefixMapping] prefix=sunshine,uri=http://sunshine.sunde.sunshine/1.0
[startElement]
uri=http://sunshine.sunde.sunshine/1.0,local=getxml,raw=sunshine:getxml
[            ] 1.
uri=http://www.w3.org/2000/xmlns/,local=sunshine,qname=xmlns:sunshine,type=C
DATA,value=http://sunshine.sunde.sunshine/1.0
[            ] 2.
uri=,local=path,qname=path,type=CDATA,value=/root/lkfmPageTitle
[            ] 3.
uri=,local=context,qname=context,type=CDATA,value=MyContext
[endElement]
uri=http://sunshine.sunde.sunshine/1.0,local=getxml,qname=sunshine:getxml
[endPrefixMapping] prefix=sunshine
[endDocument]

then after passing through sunShine transformer I still get as output :

<?xml version="1.0" encoding="UTF-8"?>
<sunshine:createcontext xmlns:sunshine="http://sunshine.sunde.sunshine/1.0"
name="MyContext"/><sunshine:setxml
xmlns:sunshine="http://sunshine.sunde.sunshine/1.0"
path="/root/lkfmPageTitle" context="MyContext">
test</sunshine:setxml><sunshine:getxml
xmlns:sunshine="http://sunshine.sunde.sunshine/1.0"
path="/root/lkfmPageTitle" context="MyContext"/>

I feel really lost now... :-(

Babs
----- Original Message -----
From: "Carsten Ziegeler" <cziegeler@s-und-n.de>
To: <cocoon-users@xml.apache.org>
Sent: Tuesday, August 20, 2002 12:07 PM
Subject: RE: weird ? (sunshine, c203)


> Try putting the "log" transformer between your xslt transformer
> and the sunShine transformer - you will then get the exact
> output of the xslt transformation.
>
> I guess that either the namespace for sunshine is not set
> or wrong (some versions of Xalan forgot to output the namespace
> very rarely, so this can be the case).
>
> Carsten
>
> > -----Original Message-----



---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message