cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Willem Penterman" ...@shapers.nl>
Subject Howto Debian 3.0/Cocoon2 setup?
Date Sat, 03 Aug 2002 11:21:49 GMT
Hi,

I'm new to the list, so excuse me if I'm asking all old and dumb questions. I did my best
trying to search the archives for a solution to my problems, but I have the feeling I'm just
making things worse instead of better. First of all, I have an apt-get problem regarding packages
tomcat, tomcat4 and cocoon2. The point is, that cocoon2 won't install unless I install Tomcat
3. But I read everywhere that I better use Tomcat4 for Cocoon2 instead of Tomcat3. So now
I have both Tomcat3 and 4 running (these run fine, both on J2SE Blackdown-1.3.1-FCS), and
Cocoon2 got put inside the Tomcat3 webapps dir. 

Well I was quite happy actually to see the Cocoon itself was giving me error messages. These
had something to do with some classes which were being tried to load in tomcat/webapps/cocoon2/WEB-INF/web.xml:

<init-param>
      <param-name>load-class</param-name>
      <param-value>
        <!-- For IBM WebSphere: -->
        com.ibm.servlet.classloader.Handler

        <!-- For Database Driver: -->
        org.hsqldb.jdbcDriver
      </param-value>
    </init-param>

So I commented com.ibm..  and org.hsq... out. This got me a little further, but still I got
an error message like this:

org.apache.cocoon.ProcessingException: The sitemap handler's sitemap is not available.

(I'm not able to paste the whole stacktrace including the 'cause' at this moment, because
I can only use lynx on an ssh term from where I am at the moment, and lynx is acting weird
on me) 

Nothing was/is written to the cocoon.log file.

So I gave up on Cocoon2/Tomcat3, downloaded the 2.0.3 binaries to my tomcat4 dir and unpacked
the cocoon.war file to my webapps dir. From what I understand it should be automatically unwarred,
but I didn't get that far. I get a 500 error again , with root cause:

java.security.AccessControlException: access denied (java.util.PropertyPermission javax.xml.parsers.SAXParserFactory
read)

I found this error in the archives, with some short answers on howto change java.policy files.
But I guess I'm a little too unexperienced to understand what I should do. I tried some things
in java.policy and catalina.policy files, but with no result at all. The solution should be
in something like:

grant codeBase "file:${catalina.home}/webapps/cocoon/-" {
            permission java.util.PropertyPermission "*", "read";
            };
           
But I don't know where to put this (java.policy, catalina.policy?) and what I have to put
in there exactly, whatever i try I still get the AccessControlException. Also tried manually
unwarring cocoon.war, but didn't help aswell.

Now has anybody got this Cocoon2 thing up and running on Debian3.0/woody with any version
of Tomcat? If so, I'd really like to know what I should do to get the same results...if not,
I'm gonna try it on WinXP... Somehow I got the feeling XP isn't going to get me into more
trouble than Debian, but it would be a big disappointment now that I have all my other server
apps running on a Debian machine. And I'm sure it must be possible...but HOW?

Thankx for taking the time to read this :)

JW
Shapers
www.shapers.nl

   




Mime
View raw message