cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <h...@dvs1.informatik.tu-darmstadt.de>
Subject Re: esql - oracle stored procedure returns resultset
Date Tue, 30 Jul 2002 13:28:15 GMT
On 30.Jul.2002 -- 03:15 PM, Frank Taffelt wrote:
> the final chapter:
> "...
> Oracle itself can only return result sets from a 'naked' query, or via a
> cursor as a stored procdure output parameter. The latter is not available
> from
> standard JDBC, only the extension to JDBC,
> CallableStatement.getResultSet(int paramindex)
> available from Oracle drivers. ..."

Ah, this is where @resultset-from-object="1" comes back into play:
Have that parameter registered as object and automagically the first
(just noticed a bug: currently only the first) parameter is turned
into the current ResultSet! :-)

So you need to return a cursor as first parameter and use
@resultset-from-object="1"

	Chris.

Please follow up summarizing your problem and which suggested solution
/ information worked for you when you consider your problem
solved. Add "SUMMARY: " to the subject line. This will make FAQ
generation and searching the list easier. In addition, it makes
helping you more fun. Thank you.

-- 
C h r i s t i a n       H a u l
haul@informatik.tu-darmstadt.de
    fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message