cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens-Christoph Brendel <Jens-Christ...@web.de>
Subject strange sitemap problem
Date Thu, 04 Jul 2002 11:37:01 GMT
Hi!

As a cocoon newbie I have the following relative strange problem - at least
from my point of view.
I would highly appreciate any hint or help to put me in the right
direction.

First I created a simple XML document and a XSLT stylesheet and placed
these documents in
one of the cocoon sample subdirectories ("protected"). I edited the
subsitemap under
$COCOON_HOME/protected and added the following entry as a reference to my
documents:

<map:match pattern="start">
        <map:generate src="docs/index.xml"/>
        <map:transform src="stylesheets/spage.xsl"/>
        <map:serialize/>
 </map:match>

I tested this with in my browser with
http://localhost/cocoon/protected/start and all worked
fine.

Then I duplicated the protected subdirectory under the new name "logbook"
with

cp -pr protected logbook.

I also duplicated the entry in the root sitemap that redirects the URI and
maps the
subsitemap. I exchanged the word "protected" with "logbook"  in these
lines. The result was

<!-- logbook webapp example pipeline -->
<map:pipeline>
    <map:match pattern="logbook/**">
    <map:mount uri-prefix="logbook" src="logbook/" check-reload="yes"/>
    </map:match>
</map:pipeline>

I would now expect that 'http://localhost/cocoon/logbook/start' will work
as well.

But what I got instead is a
" org.apache.avalon.framework.configuration.ConfigurationException:
 Error in sitemap configuration :" (!?!):

Original exception : java.lang.ClassNotFoundException:
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
at org.apache.cocoon.util.ClassUtils.loadClass(ClassUtils.java:46)
at
org.apache.cocoon.sitemap.AbstractSitemap.load_component(AbstractSitemap.java:220)
at
org.apache.cocoon.www.logbook.sitemap_xmap$Configurer.configGenerators(sitemap_xmap.java:197)
at
org.apache.cocoon.www.logbook.sitemap_xmap.configure(sitemap_xmap.java:142)
at
org.apache.avalon.excalibur.component.DefaultComponentFactory.newInstance(DefaultComponentFactory.java:172)
at
org.apache.avalon.excalibur.component.ThreadSafeComponentHandler.initialize(ThreadSafeComponentHandler.java:84)
at
org.apache.cocoon.components.language.generator.GeneratorSelector.addGenerator(GeneratorSelector.java:135)
at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.addCompiledComponent(ProgramGeneratorImpl.java:356)
at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.generateResource(ProgramGeneratorImpl.java:334)
at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.createResource(ProgramGeneratorImpl.java:282)
at
org.apache.cocoon.components.language.generator.ProgramGeneratorImpl.load(ProgramGeneratorImpl.java:196)
at org.apache.cocoon.sitemap.Handler.run(Handler.java:228)
at java.lang.Thread.run(Thread.java:496)


I haven't the slightest idea why this happens. The sitemaps under
"protected" and "logbook" are
identical. The two entries for "protected" and "logbook" in the root
sitemap differ only in the name
of the respective directories.

If someone knows what I'm doing wrong, please mail me a correction.

Many thanks in advance

Jens-Christoph Brendel

P.S: I use cocoon 2.0.1 under Mac OS X 10.1.5 (build 5S66) together with
Tomcat 3.2.2 and Apache 1.3.



---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message