cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: 2.0.2 -> 2.0.3: ClassNotFoundException on startup
Date Sat, 27 Jul 2002 04:24:55 GMT
> From: Mark S. Kent [mailto:mark.kent@vistyx.com]
> 
> > 0. Do you use the *same* JRE to compile and run Cocoon?
> 
> Yes.
> 
> > 1. Check that user you use to launch tomcat can read jars:
> > chmod 666 $TOMCAT_HOME/webapps/cocoon/WEB-INF/*
> >
> > Or even: chmod -R 666 $TOMCAT_HOME/webapps/cocoon
> 
> All files/folders are owned by tomcat.dev.  I left the permissions
alone
> (for now).
> 
> > 2. Check that your java can read these jars:
> > java -cp $TOMCAT_HOME/webapps/cocoon/WEB-INF/cocoon-2.0.3.jar:...
> 
> I think it should be: ".../WEB-INF/lib/coc...."
> 
> > org.apache.cocoon.Cocoon
> >
> > If all is ok, should say:
> >
> >   Exception in thread "main" java.lang.NoSuchMethodError: main
> >
> > Repeat same for org.hsqldb.jdbcDriver.
> 
> I chnged to the $TOMCAT_HOME/webapps/cocoon/WEB-INF/lib folder
> and this is what I got:
> ===========================================================
> [root@xxxxx lib]$ java -cp hsqldb-1.61.jar org.hsqldb.jdbcDriver
> Exception in thread "main" java.lang.NoSuchMethodError: main
>     [this one worked as expected...]
> 
>     [while the next one did not...]
> [root@xxxxx lib]$ java -cp cocoon-2.0.3.jar org.apache.cocoon.Cocoon
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/avalon/framework/logger/AbstractLoggable

That's ok: it is in another jar file. But at least, this confirms that
your java can read jar files.


>         at java.lang.ClassLoader.defineClass0(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:496)
>         at
>
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:117)

My last guess: Do you want to try running Tomcat *without* security
manager?


> I did the build from the source version of the 2.0.3 distribution and
I use
> JDK 1.3.  Should I have gotten the bin for the JDK 1.2/1.3?

No, that's sounds perfectly fine.

Vadim


> mark
> 
> > Vadim


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message