cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: action not working
Date Tue, 30 Jul 2002 17:04:17 GMT
> From: sylviat [mailto:sylviat84@yahoo.com]
> 
> Vadim, thanks a lot for your reply.  I now understand
> the '../1' syntax.  Unfortunately though it seems that
> this is not the problem.
> 
> The matchers in my pipeline are hard coded, ie:
> 
> <map:match pattern="abc">
>  <map:act set="employee">
>     <map:generate  type="serverpages" src="abc.xsp" />
>     <map:transform src="abc.xsl" />
>     <map:serialize />
>   </map:act>

If action set did not returned result (i.e., no action were executed),
sitemap processing will continue, which will result in 404. You can add
here something like:

    <map:generate  type="serverpages" src="no-actionset.xsp" />
    <map:transform src="some.xsl" />
    <map:serialize />

> </map:match>

Then you always will get some result on this URL.


Vadim


> I am getting "The requested URI /cocoon/demo/abc" was
> not found." message (I am running from the subsitemap
> "demo").  But when I comment out <map:act set..> and
> </map:act> it runs fine.  I also tried this from the
> main sitemap with the same bad results.
> 
> Originally, I cloned the /forms/employee pipeline (it
> uses the db actions ), changed the 'src' attributes
> for generate and transform files, and put those files
> in /docs/samples/forms - just like the /forms/employee
> pipeline.  It works fine from there with the action
> and all, but not from anywhere else.
> 
> Any ideas?  Again, thanks so much for your help and
> effort.
> Sylvia
> 
> --- Vadim Gritsenko <vadim.gritsenko@verizon.net>
> wrote:
> > > From: sylviat [mailto:sylviat84@yahoo.com]
> > >
> > > Hello -
> > >
> > > I am a new cocoon user having a problem with
> > > getting
> > > an action to run from a pipeline.  There is a FAQ
> > > which describes my problem exactly "Why does
> > > Cocoon
> > > return an error when I add an action to a
> > > pipeline?".
> >
> > Here is some info on topic of '../' syntax:
> >
 http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=102441015928210&w=2
> >
> > > I am sure the answer given is correct but I
> > > honestly
> > > don't understand it.  That's probably because I
> > > don't
> > > know that much about cocoon yet.
> > >
> > > I'm under some pressure to get my code up an
> > > running.
> > > Could someone please describe, in simpler terms,
> > > what
> > > to do to fix this problem and perhaps give a bit
> > > of an
> > > example?  I'd also be glad to read documentation
> > > if
> > > someone could point it out.  Is there an archive?
> >
> > http://xml.apache.org/cocoon/mail-archives.html
> >
> > Vadim
> >
> >
> > > thanks, Sylvia


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message