cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Hoegg <rho...@isisnetworks.net>
Subject Installation error using JDK 1.4.0: libawt and libXp
Date Mon, 24 Jun 2002 17:27:14 GMT
Hello Peter, and everyone,

In the message linked below, you respond to another user with a very 
similar problem to mine.

http://www.mail-archive.com/cocoon-users%40xml.apache.org/msg12493.html

I am using JDK 1.4.0, Tomcat 4.0.4, and Cocoon 2.0.2.  I do not have X 
installed, and my CATALINA_OPTS environment variable is 
'-Djava.awt.headless=true'.  After building from source, I get errors 
trying to load the default Cocoon2 site.  The stack trace shows an 
attempt to load an SVGSerializer using batik.  The error I get is:

org.apache.cocoon.ProcessingException: Error compiling sitemap: 
java.lang.UnsatisfiedLinkError: 
/usr/local/j2sdk1.4.0/jre/lib/i386/libawt.so: libXp.so.6: cannot open 
shared object file: No such file or directory

To be sure, I created a servlet that outputs 
System.getProperty("java.awt.headless"); it returns true.

Can anyone provide any insight to this situation?

Thanks,
Ryan Hoegg


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message