cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From M Al-yahya <...@Cs.Nott.AC.UK>
Subject Re: Lucene and cocoon-view
Date Fri, 21 Jun 2002 11:09:13 GMT
Hi Lajos,

Thanks for your reply.
1. I can not find a SimpleLuceneXMLIndexerImpl in the core.log
2. The view is not working. When I request 
	http://localhost:8080/cocoon/myapps?cocoon-view=content
   I see the transformed page which I could see using :
	http://localhost:8080/cocoon/myapps
   and not the actual xml content.

I think I'm having a problem with views, I've read the documentations
and looked at examples but could not figure out what is wrong here.

Cheers,
Maha

Lajos Moczar wrote:
> 
> Hi Maha -
> 
> Do you have a message in core.log from SimpleLuceneXMLIndexerImpl saying
> something about "Ignoring ... "? Check that the view is working
> correctly: call http://localhost:8080/cocoon/myapps?cocoon-view=content
> and make sure it is returning XML with a mime-type of text/xml. If not,
> Lucene will ignore it. Of course, http://localhost:8080/cocoon/myapps
> has to be a real URI.
> 
> Regards,
> 
> Lajos
> galatea.com
> Cocoon training, consulting & support
> 
> Maha Al-Yahya wrote:
> 
> > Hi Lajos,
> > Good for you, but unfourtunately I'm still having a problem running the
> > search on my webapp. I use the sample search with cocoon and input the
> > base URL as:
> > http://localhost:8080/cocoon/myapps
> > (Iwant cocoon to search all documents in myapps directory)
> >
> > in myapps sub-sitemap I put the following within components:
> > <map:views>
> >  <map:view name="content" from-label="content">
> >  <map:serialize type="xml"/>
> > </map:view>
> > <map:view name="links" from-position="last">
> >  <map:serialize type="links"/>
> >
> > and in the pipeline section of myapps sitemap like this:
> > <map:match pattern="*.*">
> >   <map:generate src="documents/{1}.{2}.xml"/>
> >   <map transform src="stylesheets/{2}.xsl label="content"/>
> >   <map:serialize/>
> > </map:match>
> >
> > However when I click on create button, the created false value turns to
> > true and when I see the statistics page everthing is zero and If I search
> > for any word nothing appears. I checked the log files but nothing helped.
> >
> > Any advice or suggestions?
> >
> > Cheers,
> > Maha
> >
> > On Thu, 20 Jun 2002, Lajos Moczar wrote:
> >
> >
> >>I found my problem; just an oopsee (yes, this is a technical term ;) ),
> >>nothing wrong with Cocoon 2.0.2. I had defined a view called "content"
> >>but fat-fingered the map:views section into the map:components section.
> >>Once I fixed that, Lucene worked like a charm.
> >>
> >>Lajos
> >>
> >>
> >>leo leonid wrote:
> >>
> >>
> >>>On Thursday, June 20, 2002, at 04:12  Uhr, M Al-yahya wrote:
> >>>
> >>>
> >>>>Hi Leo,
> >>>>
> >>>>I'm using Cocoon's latest release cocoon 2.0.2 and Tomcat 4.0.4-b3
> >>>>
> >>>>Cheers,
> >>>>Maha
> >>>>
> >>>>
> >>>hmm... I never used the 2.0.2 release, I always used the CVS version,
> >>>and everything was fine till beginning of may
> >>>(long after the 2.0.2 release) (On may 8 I sent my first mail about this
> >>>problem to this list.) Thats why I connected this problem with 2.1-dev.
> >>>
> >>>Anyway, I now use the 2.0.3 branch and where view-labels within
> >>>aggregation and indexing the docs is possible.
> >>>But the problem exits (still or again) in the CVS HEAD branch.
> >>>/Leo
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>>leo leonid wrote:
> >>>>
> >>>>
> >>>>>On Thursday, June 20, 2002, at 02:57  Uhr, M Al-yahya wrote:
> >>>>>
> >>>>>
> >>>>>>Hello,
> >>>>>>
> >>>>>>I'm experimenting with cocoon XML search using lucene.
> >>>>>>
> >>>>>
> >>>>>You are using the the 2.1-dev version of cocoon, right?
> >>>>>
> >>>>>
> >>>>>>At
> >>>>>>http://localhost:8080/cocoon/search/create if I input the base
URL
> >>>>>>as it
> >>>>>>is :
> >>>>>>http://localhost:8080/cocoon/documents/index.html the creation
goes on
> >>>>>>well and the search is good. However, if I input the base URL:
> >>>>>>http://localhost:8080/cocoon/mywebapp/index.html
> >>>>>>the index statistics shows everything 0 and I don't see anything
> >>>>>>helpful
> >>>>>>in the logs. I think it has to do with the statement "The base
url
> >>>>>>should be cocoon-view aware of content-labels links, and content."
I've
> >>>>>>read the concepts/view section of the documentation but could
not
> >>>>>>figure
> >>>>>>out what must I do to make my XML files cocoon-view aware.
> >>>>>>
> >>>>>>
> >>>>>everything right, only something prevents the 2.1-dev version from
> >>>>>interpreting labels within an aggregation
> >>>>>
> >>>>>
> >>>>>>Any suggestions?
> >>>>>>
> >>>>>>
> >>>>>writing a patch or waiting for the bug fix or using cocoon 2.03 :-(
> >>>>>/Leo
> >>>>>
> >>>>>
> >>>>>>Cheers,
> >>>>>>Maha
> >>>>>>
> >>>>>>---------------------------------------------------------------------
> >>>>>>Please check that your question  has not already been answered
in the
> >>>>>>FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> >>>>>>
> >>>>>>To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> >>>>>>For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
> >>>>>>
> >>>>>>
> >>>>>---------------------------------------------------------------------
> >>>>>Please check that your question  has not already been answered in
the
> >>>>>FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> >>>>>
> >>>>>To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> >>>>>For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
> >>>>>
> >>>>
> >>>>---------------------------------------------------------------------
> >>>>Please check that your question  has not already been answered in the
> >>>>FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> >>>>
> >>>>To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> >>>>For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
> >>>>
> >>>>
> >>>
> >>>---------------------------------------------------------------------
> >>>Please check that your question  has not already been answered in the
> >>>FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> >>>
> >>>To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> >>>For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
> >>>
> >>>
> >>
> >>
> >>
> >>---------------------------------------------------------------------
> >>Please check that your question  has not already been answered in the
> >>FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> >>
> >>To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> >>For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
> >>
> >>
> >
> >
> > ---------------------------------------------------------------------
> > Please check that your question  has not already been answered in the
> > FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> >
> > To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> > For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>
> >
> >
> 
> --
> 
> ---------------------------------------------------------------------
> Please check that your question  has not already been answered in the
> FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>
> 
> To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>

---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message