cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Liam Morley <lmor...@gdc.wpi.edu>
Subject Re: building problem...
Date Mon, 10 Jun 2002 08:00:18 GMT
This is definitely a shot in the dark.. but here goes. Perhaps the Θ 
character in the name of a parent directory is not within any of the 
character sets that your java version supports (if you are running with 
jdk1.4, you can see what charsets you have by looking at the Charset 
<http://java.sun.com/j2se/1.4/docs/api/java/nio/charset/Charset.html> 
class). It appears that the build error is in build.xml, not in any 
Cocoon classes. If you go to line 1093 in build.xml, it's as follows:

<fileset dir="${build.context}"/>

my only guess is that it doesn't understand the characters in your 
parent directory, causing it to die on constructing the URL (hence the 
MalformedURLException, with "d" as the protocol and the drive are 
working with). Try other directories, like "D:\xml-cocoon2\" or even 
"C:\xml-cocoon2\". Again, this is a stab in the dark, and I really have 
no clue. Best of luck.

Liam Morley


Patrick.Pierra@linedata.com wrote:

>I had a problem in building cocoon with the version 2.0.2. Vadim and Perry
>have me advised to try the 2.0.3 version.
>I tried it but i have the same error in building cocoon with this version.
>
>The error is :
>************************************************************************************************************************************************************
>prepare-webapp:
>[xconf-tool] Reading: D:
>\tΘlΘchargement\cocoon\dezip2\xml-cocoon2\build\cocoon\webapp\sitemap.xmap
>
>BUILD FAILED
>
>D:\tΘlΘchargement\cocoon\dezip2\xml-cocoon2\build.xml:1093: IOException:
>java.net.MalformedURLException: unknown protoco
>l: d
>
>Total time: 2 minutes 22 seconds
>************************************************************************************************************************************************************
>
>If someone could help me to solve it....
>
>Regards,
>
>
>Patrick PIERRA
>Linedata Services Luxembourg
>00 352 29 56 65 282
>patrick.pierra@linedata.com
>www.linedata.com
>



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message