cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cnsxx...@netscape.net
Subject RE: sitemap is not available
Date Wed, 05 Jun 2002 08:23:33 GMT
Hi,

I tried adding the cocoon jar file to catalina/common/lib/ but then I get a *deployment* error
as it needs/relies-on other jar files. I could end up copying the entire contents of WEB-INF/lib/
into catalina/lib/ and it will probably work.....but I feel that this can't be the solution.

Does anyone have a clue as to why the Coccoon classes are found for the Cocoon samples but
not for my pipeline?

TIA

C
-=

cnsxxx09@netscape.net wrote:

>Hi,
>
>I had problems deploying Cocoon in JBoss 3 as a .war, so I tried putting it into a .ear
file and it worked! (JBoss RC3/Catalina).
>
>So, I can run all the examples successfully.....
>
>But I cannot get my own Pipeline to work....the error I get is:
>"org.apache.cocoon.ProcessingException: The sitemap handler's sitemap is not available.
Please check logs for the exact error."
>
>and when I look in the logs I see the error:
>": Error compiling sitemap
>java.lang.NoClassDefFoundError: org/apache/cocoon/generation/ServletGenerator"
>
>This file is in the cocoon JAR file...which exists in the WAR file within WEB-INF/lib
>
>But what I cannot understand is the fact that all of the examples work okay, e.g. http://localhost:8080/cocoon/sub/
because this would indicate that the cocoon JAR file *is* deployed and found....but my own
stuff in
>http://localhost:8080/cocoon/myfiles/ throws the missing class error
>(rather than a resource not found error...so I know my pipeline is ok).
>
>Is there an extra classpath setting needed for the pipeline?
>
>TIA
>
>C.....
>-=-=-=


__________________________________________________________________
Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience
of buying online with Shop@Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message