cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Argyn Kuketayev <Argyn.Kuketa...@plateau.com>
Subject RE: iPlanet 6.5 + Cocoon - is there still problem with serv;et co ntainer?
Date Mon, 03 Jun 2002 16:58:33 GMT
> Don't know exactly what problem you're talking about but

I mean this: 
"iPlanet Web Server 4.x provides the servlet 2.2 API (javax.servlet.*
classes), but the servlet engine doesn't handle servlet contexts. This means
there is no classloader built with the contents of WEB-INF/classes and
WEB-INF/lib and that resolution of context resources (using
ServletContext.getResource()) doesn't give the expected results." 

cited from http://xml.apache.org/cocoon/installing/index.html

> I have Cocoon 2.0.2 (with Saxon 6.5.2, jexen) running under iAS 6.5
> on w2k and Sol8. I don't remember running into any problems.

nice to hear it. many thanks.

unfortunately, C2 installation document doesn't say anything about iPlanet
6.5 :(
is the following statement still true? 

"To be able to run on such non-compliant engines, Cocoon provides a
bootstrap servlet in org.apache.cocoon.BootstrapServletthat handles all the
servlet context related behaviours needed for proper functioning. " from the
above doc.


thanks,
Argyn

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message