cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Volker Schneider" <volker.schnei...@danet.de>
Subject Urgent: i18n and xsp:element does not work!
Date Wed, 26 Jun 2002 07:51:54 GMT
Dear colleagues,

I have a problem using the xsp:element tag with i18n.

I have this pipeline (the catalog works fine):

<map:match pattern="RX">
  <map:generate type="serverpages" src="../xsp/rx.xsp"/>
  <map:transform type="i18n"/>
  <map:serialize type="xml"/>
</map:match>

and my xsp:

<?xml version="1.0" encoding="UTF-8"?>

<xsp:page xmlns:xsp="http://apache.org/xsp"
          xmlns:xsp-session="http://apache.org/xsp/session/2.0"
          create-session="true">

<service xmlns:i18n="http://apache.org/cocoon/i18n/2.0">

  <!-- (1) -->
  <input_city id="startcity" label="xy" i18n:attr="label"/>

  <!-- (2) -->
  <xsp:element name="input_city">
	<xsp:attribute name="id">startcity</xsp:attribute>
    <xsp:attribute name="label">xy</xsp:attribute>
    <xsp:attribute name="i18n:attr">label</xsp:attribute>
  </xsp:element>
</service>
</xsp:page>

The result is, that (1) works fine, but (2) does not!!!

The result is:

<?xml version="1.0" encoding="UTF-8" ?>
  <service xmlns:xsp="http://apache.org/xsp"
xmlns:xsp-session="http://apache.org/xsp/session/2.0"
xmlns:i18n="http://apache.org/cocoon/i18n/2.0">
    <input_city id="startcity" label="City:" />
    <input_city id="startcity" label="xy" i18n:attr="label" />
</service>

Can anybody help me please?

Thank you, best regards
- Volker -


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message