cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Vogelheim <b...@daniel-vogelheim.de>
Subject Re: Can't connect to MySQL with Cocoon 2
Date Sun, 05 May 2002 14:03:43 GMT
Hello Zack,

>Apparently a lot of people have been having trouble getting mySQL+C2 to work
>with the 1.4 JDK. I'd try 1.3 and see if that helps any. HTH.

Thanks; that solves it. With IBM's JDK 1.3 my setup worked right away.

The reason I used JDK 1.4 is because I don't run X. According to the
FAQ, only JDK 1.4 can run in 'headless' mode, and indeed with JDK 1.3
Cocoon doesn't start unless I also run X. So my problem is solved for
now, but I'm hoping for a better long-term solution (i.e., no X, and
still MySQL access).

Thanks everyone!

Sincerely,
Daniel


[original problem was:]
>> I have a problem connecting to a MySQL database with Cocoon. When I
>> try to access a page that goes through the SQLTransformer, the browser
>> doesn't deliver any result. There's no error message, the browser just
>> sits there and waits for data. The Coccon core.log file contains an
>> error message "No valid Jdbc Connection class available". (More
>> details follow below.)
>> 
>> I've checked Google, the mailing list archive, and the FAQs, but
>> didn't find anything that seemed to help. I'm surely missing
>> something; aynone out there can help me?
[snip]

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message