cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Argyn Kuketayev <Argyn.Kuketa...@plateau.com>
Subject RE: is there an issue with international characters in XSP (C2.0. 1)?
Date Wed, 08 May 2002 20:29:37 GMT
my porblem is this: I get correctly 3 bytes per chinese symbol. in the xml
page they are rendered very strangely: first byte come as is, the next two
bytes are encoded like &#130;&#145; etc. So, instead of showing one UTF-8
symbol, it trashes me with three wrong caracters.



> -----Original Message-----
> From: KOZLOV Roman [mailto:r-kozlov@opencascade.com]
> Sent: Wednesday, May 08, 2002 2:11 AM
> To: cocoon-users@xml.apache.org
> Subject: Re: is there an issue with international characters 
> in XSP (C2.0.1)?
> 
> 
> Hi Argyn,
> 
> I've the same but I can see right presentation in a browser.
> 
> Roman
> 
> Argyn Kuketayev wrote:
> 
> > I'm retrieving UTF-8 data from Oracle table. I put UTF-8 
> encoding in my XSP
> > page. then I use XML-serializer to see what's coming out. I 
> have some
> > chinese words in the varchar2 field, I see that they are 
> "&#145;" and so on
> > in the XML file produced, which is apparently wrong. Any ideas?
> >
> > Argyn
> >
> > 
> ---------------------------------------------------------------------
> > Please check that your question has not already been answered in the
> > FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
> >
> > To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> > For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
> 
> 
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
> 
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
> 

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message