cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Savory <and...@luminas.co.uk>
Subject RE: SVG BUG?: The attribute 'xlink:href' of the element <image> is required
Date Mon, 22 Apr 2002 08:11:02 GMT
On Mon, 22 Apr 2002, Conal Tuohy wrote:

> When you say you've had problems with relative hrefs, do you mean you have
> used images in SVG? Or were your href problems in some other context?

Yes, it was with SVG. Here's an example that works for me:

<?xml version="1.0"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
  <xsl:template name="image-details">
    <svg width="{dimension_x}" height="{dimension_y}" xmlns="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink">
      <image x="0" y="0" width="{dimension_x}px" height="{dimension_y}px" xlink:href="http://www.luminas.co.uk/images/object_images/{filename}"/>
      <text x="10px" y="{dimension_y - 10}px" style="font-family:sans; font-size:8pt; fill:#000000">
         Copyright &#169; <xsl:value-of select="repository"/>
      </text>
    </svg>
  </xsl:template>
</xsl:stylesheet>


Andrew.

-- 
Andrew Savory                                Email: andrew@luminas.co.uk
Managing Director                              Tel:  +44 (0)870 741 6658
Luminas Internet Applications                  Fax:  +44 (0)870 28 47489
This is not an official statement or order.    Web:    www.luminas.co.uk


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message