cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark S. Kent" <mark.k...@vistyx.com>
Subject SAXParser not implementing XMLReader causing TC 4.0.3 load failure
Date Tue, 16 Apr 2002 21:06:38 GMT
I just installed Tomcat 4.0.3 on my WinNT4 SP5 laptop (replacing Tomcat
4.0.1) and trying to use my existing Cocoon 2.0.2 build with it and I'm
seeing this error:

  SAX2 driver class org.apache.xerces.parsers.SAXParser does not implement
XMLReader

I've seen some previous messages about this and even tried Vadim's
workaround of
  "1. Move xalan/xerces/xml-apis/batik from cocoon/WEB-INF/lib to the
tomcat/common/lib
   2. Add extra-classpath parameter ..."
but still cannot get Tomcat to correctly deploy Cocoon2.  Am I missing
something?  I'm using JDK1.3.1 (although I don't think that matters at this
point).

I've noticed that Vadim's batik version was "batik-libs-1.1.1.jar" while the
only one I can find in anay of my downloads/packages is
"batik-all-1.5b1.jar".  The filenames (and likely contents) are different.
Will that version work the same as a "batik-libs-XXX.jar" version?


Mark



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message