cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barbara Post" <bab...@ifrance.com>
Subject Re: Cocoon2 with Tomcat 4.0.1 (in JBuilder 6 Enterprise)
Date Fri, 26 Apr 2002 13:19:19 GMT
Hi Konstantin,

Well, I took out Cocoon (after war deployment) and removed unnecessary
things, then used the remaining to create my own webapp (indeed created thru
JB6), into e:\myproject. I take care of checking that my web.xml is not
overwritten...

I then choose web run.

Maybe my sitemap is wrong ? in web.xml the welcome-file is index.html
although it does not exist, and my first pipelines are the following, this
should handle the URL correctly, shouldn't it ?

Besides, I even can't run examples that are defined in JB's Tomcat's
server.xml, they're not found !! Have to check this first, however Tomcat is
running.

Thank you anyway, this helps.

Babs
-------------------------------------------------------

<!-- home page redirect and session handling -->
  <map:pipeline>
   <map:match pattern="">
    <map:redirect-to uri="index" />
   </map:match>
  </map:pipeline>
  <!-- authentication -->
<map:pipeline>
   <map:match pattern="index*" session="true">
    <map:act type="form-validator">
     <map:parameter name="descriptor"
value="context://descriptors/authenticationformdesc.xml"/>
     <!-- params ok -->
     <map:act type="authenticationAction">
      <map:parameter name="validate" value="company, username, password"/>
      <!-- no error msg, set session params, create new map, go to menu -->
      <map:redirect-to uri="menu"/>
     </map:act>
     <!-- error, return empty map, go to error page -->
      <map:redirect-to uri="error"/>
     </map:act>
    <!-- missing params -->
    <map:redirect-to uri="errorparam"/>
   </map:match>
..............
----- Original Message -----
From: Konstantin Piroumian <kpiroumian@apache.org>
To: <cocoon-users@xml.apache.org>
Sent: Friday, April 26, 2002 2:49 PM
Subject: Re: Cocoon2 with Tomcat 4.0.1 (in JBuilder 6 Enterprise)


>
> I suspect that you have created a WebApp element in JB6 and you are trying
> to start it from there. Look at the WEB-INF/web.xml and you'll notice that
> JB has replaced it with its own. This brings up the errors you get.
>
> Here is the sequence I use to run Cocoon from JB:
>     - copy cocoon.war to <tomcat>/webapps
>     - run Tomcat from <tomcat>/bin/startup.bar once, so it deploy the
> application
>     - try that it works accessing the http://localhost:8080/cocoon/
>     - shutdown Tomcat
>
> Then in JB
>     - clear the checkbox in Webapp properties telling to build the WAR
>     - select a start page (say, /samples/i18n/simple.xml)
>     - then choose Web Run from its context menu
>
> This way it works for me.
>
> --
>   Konstantin
>


 
______________________________________________________________________________
ifrance.com, l'email gratuit le plus complet de l'Internet !
vos emails depuis un navigateur, en POP3, sur Minitel, sur le WAP...
http://www.ifrance.com/_reloc/email.emailif



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message