cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Jellinghaus <r...@unrealities.com>
Subject Cannot install: latest snapshot, Java 1.4, Tomcat 4.0.3LE
Date Tue, 26 Mar 2002 07:36:24 GMT
I am trying to install and run Cocoon under JDK 1.4 with Tomcat 4.0.3LE for 
Java 1.4.

I am able to download and build the latest Cocoon development snapshot 
(xml-cocoon2_20020326051833.tar.gz), doing "build dist-bin".

I then copy cocoon.war to %CATALINA%/webapps, and xml-apis.jar and 
xercesImpl-2.0.0.jar to %CATALINA%/lib (otherwise I get an "class 
org.w3c.dom.ranges.DocumentRange not found" error when starting).

I start Tomcat, and it expands cocoon.war.  I go to 
http://localhost:8080/cocoon and I get:

Cocoon 2 - Internal server error
type fatal
message Error compiling sitemap
description org.apache.cocoon.ProcessingException: Error compiling sitemap: 
java.lang.NoSuchFieldError: manager

Why am I getting this error?

(I'm not even going to mention all the troubles I had trying to get Cocoon 
2.0.1 to work under Java 1.4....)

I rolled back to Java 1.3.1 and Tomcat 4.0.1 and Cocoon 2.0.1 (built from 
source) and it works.  Still, it is disappointing that I was totally unable 
to get Cocoon to work under the latest version of Java.  Will Cocoon 2.0.2 
improve matters?  Or was there some other way to deal with this 
"NoSuchFieldError" I encountered?

Thanks very much for any hints.
Cheers,
Rob


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message